activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sampangi Apparao <sampangi_appa...@yahoo.com>
Subject ActiveMQ transport message through jgroups
Date Sat, 10 Feb 2007 00:08:03 GMT

Hi,
I am facing a problem, while jgroups transport scheme is using.

I am getting following error message.
 
Caught: javax.jms.JMSException: Could not connect to broker URL:
jgroups:default. Reason: java.io.IOException: Transport scheme NOT
recognized: [jgroups]
javax.jms.JMSException: Could not connect to broker URL: jgroups:default.
Reason: java.io.IOException: Transport scheme NOT recognized: [jgroups]
	at
org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:32)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:254)
Caught: javax.jms.JMSException: Could not connect to broker URL:
jgroups:default. Reason: java.io.IOException: Transport scheme NOT
recognized: [jgroups]
Caught: javax.jms.JMSException: Could not connect to broker URL:
jgroups:default. Reason: java.io.IOException: Transport scheme NOT
recognized: [jgroups]
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:212)
	at
org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:159)
	at jgroup.fund.test.App$HelloWorldProducer.run(App.java:86)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: Transport scheme NOT recognized: [jgroups]
	at
org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:24)
	at
org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:170)
	at
org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:75)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:224)
	... 4 more
Caused by: java.io.IOException: Could not find factory class for resource:
META-INF/services/org/apache/activemq/transport/jgroups
	at
org.apache.activeio.util.FactoryFinder.doFindFactoryProperies(FactoryFinder.java:87)
	at
org.apache.activeio.util.FactoryFinder.newInstance(FactoryFinder.java:57)
	at
org.apache.activeio.util.FactoryFinder.newInstance(FactoryFinder.java:46)
	at
org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:166)
	... 6 more

if any body have the solution then,
could you please forward the solution for the above issue.
thanks in advance.

-- 
View this message in context: http://www.nabble.com/ActiveMQ-transport-message-through-jgroups-tf3203582s2354.html#a8895928
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message