activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano <l.monteb...@almavivaitalia.it>
Subject Re: JCA adapter and Spring 2 application conflict in JBoss
Date Thu, 08 Feb 2007 11:12:03 GMT

I don't use xbean-spring in my application, but however I reproduced the
error with an application example of the Spring 2.0.2 distribution the
jpetstore. 
To try yourself these are the steps:
1)Install a fresh Jboss (I tested 4.0.3 and 4.0.5) and verify it starts
without problems
2)Stop JBoss
3)Put the activemq-rar-4.1.0-incubator.rar and jpetstore.war in the deploy
JBoss dir
4)Start JBoss and you will see my stack trace

Note that if you install only the jpetstore.war and deploy
activemq-rar-4.1.0-incubator.rar while
JBoss is running, you don't have any error, but restarting JBoss it will
show again.
It seems a classloader problem, even because if I delete the spring-2.0 jar
inside the rar, JBoss start fine, but where open a bug?. What problems I
could encounter with this last rar modification?

Luciano


James.Strachan wrote:
> 
> On 2/8/07, Luciano <l.montebove@almavivaitalia.it> wrote:
>>
>> If you are referring to the ActiveMQ JCA rar, as I stated in my original
>> post, I already use 4.1.0 version. The 4.0.3 I talked about is the Jboss
>> version (and the last JBoss is 4.0.5).
> 
> Sorry - I misread your mail :)
> 
> So the stack trace you provide doesn't seem to be related to the RAR
> at all - it seems the error is being thrown when a WAR starts up
> parsing /WEB-INF/applicationContext.xml. Could you show us what it
> looks like? Are you using some ActiveMQ XML in there? If so what
> verison of xbean-spring are you using?
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/JCA-adapter-and-Spring-2-application-conflict-in-JBoss-tf3189496s2354.html#a8863428
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message