activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique DE VITO <dominique.dev...@thalesgroup.com>
Subject Re: pb when compiling the ActiveMQ 4.1
Date Tue, 20 Feb 2007 17:13:15 GMT
I have re-done a Maven 2.0.5 compilation with success. I think it is the 
security specific features of our firewall that should have annoyed 
Maven download file processing.

Thanks for your answer.

Dominique


James Strachan a écrit :
> I wonder if this is some issue with maven 2.0.5 as we've all been
> using 2.0.4 and building fine for some time.  I'll try get a chance to
> try out 2.0.5 soon to see if thats the cause
>
>
> On 2/20/07, Dominique DE VITO <dominique.devito@thalesgroup.com> wrote:
>> Hi,
>>
>> I have just seen the Web Console :
>> http://activemq.apache.org/web-console.html
>>
>> I have downloaded **ActiveMQ 4.1** from SVN and entered the command (in
>> the page given above) :
>>
>> mvn clean install -Dmaven.test.skip=true
>>
>> Results :
>>
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] The plugin 'org.apache.maven.plugins:maven-clean-plugin' does not
>> exist or no valid version could be found
>>
>> Well, my proxy configuration is quite good, as if I remove 'clean' and
>> only enter the following command :
>>
>> mvn install -Dmaven.test.skip=true
>>
>> I just can see Maven to download files:
>>
>> [INFO] artifact org.apache.maven.plugins:maven-site-plugin: checking for
>> updates from apache.incubating.releases
>> [INFO] artifact org.apache.maven.plugins:maven-site-plugin: checking for
>> updates from central
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-5/maven-site-plugin-2.0-beta-5.pom

>>
>> 2K downloaded
>> Downloading:
>> http://people.apache.org/repo/m2-incubating-repository/org/apache/maven/plugins/maven-plugins/1/maven-plugins-1.pom

>>
>> [WARNING] Unable to get resource
>> 'org.apache.maven.plugins:maven-plugins:pom:1' from repository
>> apache.incubating.releases
>> (http://people.apache.org/repo/m2-incubating-repository)
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-plugins/1/maven-plugins-1.pom

>>
>> 3K downloaded
>>
>> I am quite surprised, the "clean" action is unknown...
>>
>> But, it runs well... until the following error:
>>
>> [WARNING] Unable to get resource 'org.apache.maven:maven:pom:2.0.2' from
>> repository apache.incubating.releases
>> (http://people.apache.org/repo/m2-incubating-repository)
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/maven/2.0.2/maven-2.0.2.pom 
>>
>> 12K downloaded
>> [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
>> 'b4795d5d85175cca21e698937a6d49f5c6fc4651'; remote =
>> '816e22beec3ee5c4a344959625a824bb6202daeb' - RETRYING
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/maven/2.0.2/maven-2.0.2.pom 
>>
>> 12K downloaded
>> [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local =
>> '2e94e9293b962c1abc47f395127cbd6cbc2c0209'; remote =
>> '816e22beec3ee5c4a344959625a824bb6202daeb' - IGNORING
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>> I was running on JRE 6 with Maven 2.0.5.
>>
>> I have switched to JRE 5_08 and re-run "c:\maven-2.0.5\bin\mvn install
>> -Dmaven.test.skip=true"
>>
>> Then, I have got another error:
>>
>> Downloading:
>> http://people.apache.org/repo/m2-incubating-repository/org/apache/maven/maven-settings/2.0/maven-settings-2.0.pom

>>
>> [WARNING] Unable to get resource
>> 'org.apache.maven:maven-settings:pom:2.0' from repository
>> apache.incubating.releases
>> (http://people.apache.org/repo/m2-incubating-repository)
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/maven-settings/2.0/maven-settings-2.0.pom

>>
>> 1K downloaded
>> Downloading:
>> http://people.apache.org/repo/m2-incubating-repository/org/apache/maven/maven-artifact/2.0.2/maven-artifact-2.0.2.pom

>>
>> [WARNING] Unable to get resource
>> 'org.apache.maven:maven-artifact:pom:2.0.2' from repository
>> apache.incubating.releases
>> (http://people.apache.org/repo/m2-incubating-repository)
>> Downloading:
>> http://repo1.maven.org/maven2/org/apache/maven/maven-artifact/2.0.2/maven-artifact-2.0.2.pom

>>
>> 765b downloaded
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>> I am surprised ActiveMQ 4.1 does not compile out of the box. What's 
>> wrong ?
>>
>> Have you got any idea ?
>>
>> Thanks.
>>
>> Best regards,
>> Dominique
>>
>>
>
>


Mime
View raw message