activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Albert Strasheim <13640...@sun.ac.za>
Subject Re: Kaha store corrupted?
Date Thu, 15 Feb 2007 20:01:53 GMT
I reported the same (or a very similar) issue here:

https://issues.apache.org/activemq/browse/AMQ-1082

Maybe you could add some pertinent comments about your setup there. 
Might be that I got the wrong issue though.

Cheers,

Albert

On Thu, 15 Feb 2007, drvillo wrote:

<snip>

> I'm using a kaha store to handle manual message spooling.
> I've used with success for a week or so now but today I found 
> it unable to fetch any more message.
> I can still read the size, but once I call ListContainerImpl.remove()
> I get the following trace:

<snip>

> Needless to say there is the data-kaha-2 file:
> 
> total 341828
> -rw-r--r--  1 hostcount role  33554371 Feb 15 17:11 data-kaha-1
> -rw-r--r--  1 hostcount role  33554360 Feb 15 17:11 data-kaha-2
> -rw-r--r--  1 hostcount role  33554363 Feb 15 17:11 data-kaha-3
> -rw-r--r--  1 hostcount role  33554422 Feb 15 17:11 data-kaha-4
> -rw-r--r--  1 hostcount role  33554408 Feb 15 17:11 data-kaha-5
> -rw-r--r--  1 hostcount role  33554400 Feb 15 17:11 data-kaha-6
> -rw-r--r--  1 hostcount role  33554396 Feb 15 17:11 data-kaha-7
> -rw-r--r--  1 hostcount role    698115 Feb 15 17:11 data-kaha-8
> -rw-r--r--  1 hostcount role 114068130 Feb 15 17:11 index-kaha
> 
> but for one reason or another it's not mapped anymore in te ListContainer.
> Is it possible that restarting sometimes cause some inconsistency.
> I have to say that sometimes I've killed the process with -9...
> 
> Also: I tried to copy the files over to my local machine so to debug it,
> but once done that it seems that I read an empty store...
> 
> Thanks a lot
> Francesco

Mime
View raw message