activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: client version policy when upgrading activemq brokers
Date Mon, 15 Jan 2007 13:53:00 GMT
Generally speeking, we switch to major version numbers when things are
completely incompatible. So 3.x won't talk to 4.x etc.  When we move
in minor upgrades such as 4.0.x to 4.1.x then clients should still
work on the 4.1.x broker; though there's always a little bit of risk
that we missed something as we don't yet have an automatic integration
test to ensure that every feature on a 4.0.x client works perfectly on
a 4.1.x broker etc.


On 1/15/07, Jamie McCrindle <jamiemccrindle@gmail.com> wrote:
> hi all,
>
> do all components / applications in a system always need to be
> upgraded when moving to new versions of activemq? specifically, i'd
> like to move to activemq 4.1.0 but we have some activemq 4.0.2 client
> applications that i'd prefer to keep that way rather than doing a big
> bang migrate.
>
> regards,
> jamie.
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message