activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From raz <raziel...@gmail.com>
Subject Migrating to ActiveMQ 4.x
Date Thu, 25 Jan 2007 21:29:29 GMT

Hi. I'm trying to migrate my application to version 4.1 from 3.1.

I don't have anything elaborated but since now even the configuration
changed this is becoming quite a hassle.

My 3.x conf. looks something like:

<breans>
  <broker>
    <connector>
      <tcpServerTransport uri="tcp://localhost:61616" backlog="1000"
useAsyncSend="true" maxOutstandingMessages="50"/>
    </connector>

    <persistence>
      <berkeleyDbPersistence directory="db/bdb"/>
    </persistence>

    <security>
      <bean id="process-security-adapter"
class="com.whatever.MySecurityAdapter" />
    </security>
  </broker>

  <!-- The Derby Datasource that will be used by the Broker -->
  <bean id="derby-ds" class="org.apache.commons.dbcp.BasicDataSource"
destroy-method="close">
    <property name="driverClassName">
      <value>org.apache.derby.jdbc.EmbeddedDriver</value>
    </property>
    <property name="url">
      <!-- Use a URL like 'jdbc:hsqldb:hsql://localhost:9001' if you want to
connect to a remote hsqldb -->
      <value>jdbc:derby:derbydb;create=true</value>
    </property>
    <property name="username">
      <value></value>
    </property>
    <property name="password">
      <value></value>
    </property>
    <property name="poolPreparedStatements">
      <value>true</value>
    </property>
  </bean>
</beans>

Which as you can see is pretty much the basic example's conf. shipped with
activemq. Now that everything changed I can find somewhat a mapping for all
the previous items except for the security. The only documentation about it
says that 4.x provides pluggable security through various different
providers and that JAAS is one of them.
However, I don't see how to specify my own security plugin, like I had
before, or how can I use JAAS to get the same functionality (if possible).

Can somebody point me please in the right direction?

Also, are there anything relevant items that I should take into
consideration for completing my upgrade (considering I have a very basic
installation).


Thanks
-- 
View this message in context: http://www.nabble.com/Migrating-to-ActiveMQ-4.x-tf3119064.html#a8641351
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message