activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Adams <james_ad...@yahoo.com>
Subject Re: ActiveMQResourceAdapter
Date Tue, 23 Jan 2007 02:38:42 GMT



James Adams wrote:
> 
> 
> James.Strachan wrote:
>> 
>> On 1/22/07, James Adams <james_adams@yahoo.com> wrote:
>>>
>>>
>>> Christopher G. Stach II wrote:
>>> >
>>> > James Adams wrote:
>>> >> I'm also in search of this class.  I am using ActiveMQ version 4.1.0,
>>> and
>>> >> I
>>> >> don't see it anywhere in the JAR file Maven pulled down for this
>>> >> dependency.
>>> >>
>>> >> Is there another dependency I should add to my pom.xml in order to
>>> get
>>> >> the
>>> >> right JAR which contains this class?
>>> >>
>>> >
>>> >
>>> > The JAR is packed in the RAR in lib/optional.  You have to extract it.
>>> > Annoying, huh?
>>> >
>>> >
>>> >
>>>
>>>
>>> I've actually added the following dependency to my pom.xml and it seems
>>> to
>>> have gotten me over the hump.
>>>
>>>         <dependency>
>>>             <groupId>activemq</groupId>
>>>             <artifactId>activemq-ra</artifactId>
>>>             <version>4.0.2</version>
>>>         </dependency>
>> 
>> Here's the 4.1.0 from a maven repo...
>> 
>> http://people.apache.org/repo/m2-incubating-repository/org/apache/activemq/activemq-ra/4.1.0-incubator/
>> 
>> 
> 
> Thanks for the help.
> 
> Based on the above I added the following to my Maven2 settings.xml:
> 
>                 <repository>
>                     <id>activemq</id>
>                    
> <url>http://people.apache.org/repo/m2-incubating-repository/</url>
>                 </repository>
> 
> I also modified the ActiveMQ-RA dependency in my pom.xml to the following:
> 
>         <dependency>
>             <groupId>org.apache.activemq</groupId>
>             <artifactId>activemq-ra</artifactId>
>             <version>4.1.0-incubator</version>
>         </dependency>
> 
> Once I did this I got around the problem of not finding the
> ActiveMQResourceAdapter class.  However other bad voodoo ensued, i.e.
> there is some sort of transitive dependency problem (resulting in two
> separate geronimo-connector JARs) which makes Jencks act up, perhaps
> caused by a renamed groupId somewhere.  This is addressed in the Jencks
> user group here
> http://www.nabble.com/Outbound-JMS%3A--NoSuchMethodError%3A-Geronimo%27s-GenericConnectionManager.%3Cinit%3E-tf3060055.html#a8510668
> 
> So for now I've gone back to using the ActiveMQ-RA 4.0.2-SNAPSHOT, since
> I've been unable to figure out how to configure the correct dependency
> exclusion to get around this problem. 
> 
> 
> --James
> 


The issue turned out to have nothing to do with the 4.1.0 ActiveMQ-RA
dependency, it was instead related to my Lingo 1.3 dependency, which needed
a couple of exclusions (geronimo-connector and geronimo-transaction).  I now
find ActiveMQResourceAdapter fine, and the aforementioned NoSuchMethodErrors
are gone as well.  Now I have trouble with ActiveMQ/TranQL interaction (a
ClassCastException), but I'll post about that in another thread.

Thanks again for the attention and help with this issue.


--James
-- 
View this message in context: http://www.nabble.com/ActiveMQResourceAdapter-tf1960773.html#a8514468
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message