activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From X-Gen <x.gens...@gmail.com>
Subject ServerURL is not getting populated on ActiveMQManagedConnectionFactory
Date Fri, 19 Jan 2007 07:50:18 GMT

Greetings,

We are deploying an ActiveMQ DatasSource on JBoss, and the serverURL config
property is being ignored.
We have had a look at the source code and there is no getter/setter for this
property.
We are deploying the .rar file, this is activeMQ 4.1.0 

According to Jira AMQ-339 this was fixed previously, but it still appears to
be broken.

This part of our activemq-jms-ds.xml:

  <tx-connection-factory>
      <jndi-name>activemq/TopicConnectionFactory</jndi-name>
      <xa-transaction/>
      <track-connection-by-tx/>
      <rar-name>activemq-ra.rar</rar-name>
     
<connection-definition>javax.jms.ConnectionFactory</connection-definition>
     
<security-domain-and-application>JmsXARealm</security-domain-and-application>
      <config-property name="Clientid"
type="java.lang.String">redbox</config-property>
      <config-property name="UserName"
type="java.lang.String">user</config-property>
      <config-property name="Password"
type="java.lang.String">pass</config-property>
      <config-property name="ServerUrl"
type="java.lang.String">tcp://jms.junk:10000</config-property>
   </tx-connection-factory>

Is there any work around, or should we just add the getter/setter to
org.apache.activemq.ra.ActiveMQManagedConnectionFactory.java ?

Regards
X


-- 
View this message in context: http://www.nabble.com/ServerURL-is-not-getting-populated-on-ActiveMQManagedConnectionFactory-tf3038717.html#a8445370
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message