activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From skimstercg <Stanley.H....@uscg.mil>
Subject Re: Accessing remote AMQ with JConsole.
Date Thu, 18 Jan 2007 23:18:49 GMT

I found a solution to my problem.  The answer was unrelated to AMQ or JMX. 
It was due to weirdness in the /etc/hosts file on Red Hat Linux box.  Fixing
this, fixed RMI, which fixed JMX and all's well.  More info can be found at:

http://www.jboss.com/index.html?module=bb&op=viewtopic&t=8092&postdays=0&postorder=asc&start=0




skimstercg wrote:
> 
> I've got the exact same problem.  My set up: local box (Windows) with AMQ
> and remote box (Red Hat Linux) with AMQ.  Both boxes are running JDK
> 1.4.2.  I can use JConsole to monitor my local box but not the remote box. 
> Another clue -- I tried using the "list" command in the activemq/bin
> directory with the --jmxurl argument.  On local windows box, it works fine
> to access local AMQ url but not remote AMQ url.  If I run the list command
> on Linux box, I can access both the Windows AMQ url as well as the Linux
> AMQ url.  So it appears to be some issue with Windows box connecting
> outbound to port 1099 on another box.  My Linux admin tells me port 1099
> on the Linux box is not restristed by its firewall in any way.  From
> windows box I can telnet to port 1099 on Linux box and I can tell
> something's there listening. Anyone have any ideas?
> 
> 

-- 
View this message in context: http://www.nabble.com/Accessing-remote-AMQ-with-JConsole.-tf2971096.html#a8441334
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message