activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Wistow <si...@thegestalt.org>
Subject Re: Is anyone else seeing messages stuck on a queue?
Date Tue, 23 Jan 2007 18:27:01 GMT
On Tue, Jan 23, 2007 at 08:20:27AM +0000, James Strachan said:
> The .zip file currently only has the .bat files. The tar.gz has the
> shell scripts.  I've just patched the code so that the next nightly
> snapshot of the zip will have the unix scripts too (I often use zips
> on OS X for example :)

Doh, yeah - realised there was a .tar.gz yesterday - we had a script 
that was downloading zip files automatically for Windows and I was just 
being blind.
 
> I tried the tar.gz distro and it worked perfectly for me on OS X.
> Maybe try try tar.gz too or today's snapshot to see if it works for
> you now?

I'd got the zip file from the 15th working by running

	bin/activemq start xbean:file:conf/activemq.xml

however our unit tests still failed - we're still trying to make a 
concise test case but, essentially, using Net::Stomp under Perl we had 
been seeing some messages coming through twice, even after an ACK, or 
the broker wedging. 

With the snapshot from the 15th we found that if there were multiplke 
consumers then our problems seem to go away (with either multiple 
producers or a single producer). However if there was only a single 
consumer it sat indefinitely waiting a message (again, multiple or a 
single producer). Very odd. We're doing traces and trying to work out 
what's going on.


With the latest .tar.gz snapshot (from the 17th?) I had to use different 
command line arguments

	bin/activemq start

immediately fails with an invalid broker uri exception.


	bin/activemq xbean:activemq.xml
	bin/activemq xbean:file:conf/activemq.xml

both work (you probably know this buit incase anybody else is 
wondering). However we still see the same problems.

I can send you our test scripts if it'll help.

Simon



Mime
View raw message