activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Xbean not working with activemq-4.1
Date Thu, 14 Dec 2006 11:31:33 GMT
Try not using the snapshot XSD? FWIW the XSD might be now found on the classpath

On 12/14/06, drvillo <f.vivoli@gmail.com> wrote:
>
> Thanks for the quick reply:)
>
> Upps,
> sorry I forgot the trace -_-
>
> it fails like this:
>
> org.springframework.beans.factory.BeanDefinitionStoreException: Line 4307 in
> XML document from class path resource [net/ripe/hstcnt/jms-bare/jms.xml] is
> invalid; nested exception is org.xml.sax.SAXParseException: cos-nonambig:
> "http://activemq.org/config/1.0":redeliveryPolicy and WC[##any] (or elements
> from their substitution group) violate "Unique Particle Attribution". During
> validation against this schema, ambiguity would be created for those two
> particles.
> Caused by: org.xml.sax.SAXParseException: cos-nonambig:
> "http://activemq.org/config/1.0":redeliveryPolicy and WC[##any] (or elements
> from their substitution group) violate "Unique Particle Attribution". During
> validation against this schema, ambiguity would be created for those two
> particles.
>         at
> com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:236)
>         at
> com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(ErrorHandlerWrapper.java:172)
>         at
> com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:382)
>         at
> com.sun.org.apache.xerces.internal.impl.xs.XSConstraints.reportSchemaError(XSConstraints.java:315)
>         at
> com.sun.org.apache.xerces.internal.impl.xs.XSConstraints.fullSchemaChecking(XSConstraints.java:463)
>         at
> com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleEndElement(XMLSchemaValidator.java:2246)
>         at
> com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.endElement(XMLSchemaValidator.java:814)
>         at
> com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanEndElement(XMLNSDocumentScannerImpl.java:719)
>         at
> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1685)
>         at
> com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
>         at
> com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
>         at
> com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
>         at
> com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
>         at
> com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:250)
>         at
> com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:292)
>         at
> org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocument(DefaultDocumentLoader.java:77)
>         at
> org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:405)
>         at
> org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:357)
>         at
> org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
>         at
> org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:126)
>         at
> org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:142)
>         at
> org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:168)
>         at
> org.springframework.context.support.AbstractXmlApplicationContext.loadBeanDefinitions(AbstractXmlApplicationContext.java:113)
>         at
> org.springframework.context.support.AbstractXmlApplicationContext.loadBeanDefinitions(AbstractXmlApplicationContext.java:79)
>         at
> org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:94)
>         at
> org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:294)
>         at
> org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:92)
>         at
> org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:77)
>         at
> net.ripe.hstcnt.SpringTestSupport.createApplicationContext(SpringTestSupport.java:37)
>         at
> net.ripe.hstcnt.SpringInjectedACTestSupport.<init>(SpringInjectedACTestSupport.java:12)
>         at
> net.ripe.hstcnt.xmltest.XBeanConfigTest$XBeanTestSupport.<init>(XBeanConfigTest.java:25)
>         at
> net.ripe.hstcnt.xmltest.XBeanConfigTest$XBeanTestSupport.<init>(XBeanConfigTest.java:25)
>         at
> net.ripe.hstcnt.xmltest.XBeanConfigTest.testCreateBroker(XBeanConfigTest.java:20)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at com.intellij.rt.execution.junit2.JUnitStarter.main(JUnitStarter.java:32)
>
>
> while my xml is like:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://www.springframework.org/schema/beans"
>        xmlns:amq="http://activemq.org/config/1.0"
>        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>        xsi:schemaLocation="http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
> http://activemq.org/config/1.0
> http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd">
>     <!--  lets create an embedded ActiveMQ Broker -->
>
>     <amq:broker useJmx="false" persistent="false">
>         <amq:transportConnectors>
>             <amq:transportConnector uri="tcp://localhost:0"/>
>         </amq:transportConnectors>
>     </amq:broker>
>     <!--  ActiveMQ destinations to use  -->
>     <amq:queue id="destination"
> physicalName="org.apache.activemq.spring.Test.spring.embedded"/>
>     <!--
>      JMS ConnectionFactory to use, configuring the embedded broker using XML
>     -->
>     <amq:connectionFactory id="jmsFactory" brokerURL="vm://localhost"/>
> ...
> </beans>
>
>
>
> A note: I had to change the uri for the spring schema to
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
> because the one given by the examples (without the -2.0) didn't exist.
>
>
> Francesco
>
>
>
> James.Strachan wrote:
> >
> > Am a bit confused - how exactly doesn't it work?
> >
> > On 12/14/06, drvillo <f.vivoli@gmail.com> wrote:
> >>
> >> Hi all
> >>
> >> I've read some messages around but I still can figure out if the
> >> configuration at
> >> http://www.activemq.org/site/how-do-i-embed-a-broker-inside-a-connection.html
> >> is supposed to work right away.
> >>
> >> I'm using activemq-4.1 xbean-spring-2.7 and spring-2.0 (but tried also
> >> spring-2.0.1).
> >> It's related to
> >> http://www.nabble.com/spring-2.0-example-xml-Invalid--tf2550482.html#a7108762
> >> and
> >> http://www.nabble.com/Broken-xbeans-XSD-in-4.1-snapshot-tf2416546.html#a6736085
> >>
> >> but the xbean bug http://issues.apache.org/jira/browse/XBEAN-57
> >> is marked as fixed for 2.7, which I use.
> >> Is the whole setup supposed to work? For what I read on the activemq
> >> pages
> >> it seems so...
> >>
> >> Thanks in advance for any help
> >> Francesco Vivoli
> >> --
> >> View this message in context:
> >> http://www.nabble.com/Xbean-not-working-with-activemq-4.1-tf2819881.html#a7870648
> >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >>
> >>
> >
> >
> > --
> >
> > James
> > -------
> > http://radio.weblogs.com/0112098/
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Xbean-not-working-with-activemq-4.1-tf2819881.html#a7870761
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message