activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: Network of brokers
Date Thu, 21 Dec 2006 13:26:43 GMT
This doesn't look right.

I would recommend:

Server1:

   master1 - connector points to server2 master and server2 slave
   slave1 - connectors point to server 2 master and server2 slave

i.e. don't have a network connector to the local slave


Rob Davies
http://rajdavies.blogspot.com/


On 21 Dec 2006, at 10:55, Javier Leyba wrote:

> On 12/21/06, Marlon Santos <msantos@exist.com> wrote:
>>
>> Hi,
>>
>> well it just seems that the people behind amq are just busy. If they
>> weren't, they will be more
>> willing to help out guys.
>>
>> As to your issues, can you please post a test case, with  
>> descriptions about
>> the problem. I'll try to help in ways I can.
>>
>
>
> Hi
>
> Thanks for your reply and for clarify the problem.
>
> I've a doubt about how to configure the network of brokers.
>
> I've two JBoss Server with a master and a slave broker each one. I
> wnat to know which is the best way to configure network connectors on
> each broker (and nobody answered me).
>
> I did something like this (with static ips because I can't use  
> multicast):
>
> - In master of server1 my network connector points to
>   * server 2 master
>   * server 2 slave

>   * server 1 slave
>
> - In slave of server 1:
>   * server 2 master
>   * server 2 slave
>   * server 1 master
>
> and something similar in server 2. both with failover="true"  
> dynamicOnly="true".
>
>
> Is this ok or do you know a better way to do it ?
>
>
> Thanks in advance.
>
> -- 
> Javier Leyba
> Barcelona - Spain
> http://blog.leyba.com.ar








Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message