activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From - Lalit Nagpal - <lalitte...@gmail.com>
Subject Re: activemq-cpp release 1.0 - cant use with vs .net 2003
Date Tue, 19 Dec 2006 08:48:10 GMT

If I change the version from 8.0 to 7.0 in the vcproj files ... I can open it
with .net 2003 and build it also.
The only change that is required is to change vsnprintf to _vsnprintf in the
ActiveMQException.h file

But changing the version like this should not backfire in anyway ... so
worried .... :( .... any thoughts on this front.
It does not give any warnings/ errors so I guess should not be a problem
then.

Thanks

Lalit Nagpal
CSA, SunGard.


- Lalit Nagpal - wrote:
> 
> Hi 
> 
> I tried to use the latest release of activemq-cpp 1.0 ... and built it
> using the VS .net 2005 compiler .... Now when I try to use the lib files
> generated with my VS .Net 2003 (for some reasons I have to use it with VS
> 2003 only and not 2005) ... I run into the following errors ... any ideas
> what i can do to use the 1.0 release with VS .Net 2003 compiler
> 
> fatal error LNK1262: link failed due to mismatched versions of 'E:\Program
> Files\Microsoft Visual Studio .NET 2003\Vc7\bin\c2.dll' and LINK.EXE
> 
> We would like to switch from the previous unversioned copy that we have to
> the versioned cpp 1.0 release :).
> 
> Can somebody guide me here please. Can anything be done to give support to
> vs .net 2003 also.
> 
> Thanks
> Lalit Nagpal
> CSA, SunGard
> 

-- 
View this message in context: http://www.nabble.com/activemq-cpp-release-1.0---cant-use-with-vs-.net-2003-tf2839616.html#a7943587
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message