activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OLF <o...@afrika-virus.de>
Subject Re: Starting ActiveMQ: brokerName not set?
Date Wed, 06 Dec 2006 07:20:41 GMT

Hi,

it is the default configuration delivered with ActiveMQ 4.0.1.

regards 

Olaf


Marlon Santos wrote:
> 
> Hi, 
> 
> can you send your xml configuration?
> 
> regards,
> 
> Marlon
> 
> 
> 
> OLF wrote:
>> 
>> 
>> Marlon Santos wrote:
>>> 
>>> 
>>> 
>>> gabriel kastenbaum wrote:
>>>> 
>>>> Hi everybody,
>>>> 
>>>> I am trying to start a network of brokers. I would like to set the 
>>>> "brokerName"
>>>> by the script that starts the broker with the propertie
>>>> -Dactivemq.brokerName=$HOSTNAME
>>>> 
>>>> and in activemq.xml
>>>> 
>>>> <broker ... brokerName="${activemq.brokerName}">
>>>> 
>>>> The point is  that the brokerName is not set - or seems to be "not
>>>> set".
>>>> I have the following message in the logs: WARN 
>>>> multicast.MulticastDiscoveryAgent <BrokerName is not set>
>>>> 
>>>> 
>>>> In fact even if I hard code a name in the configuration
>>>> <broker brokerName="myHostName">
>>>> 
>>>> I have the same message.
>>>> Do I have to take into account the WARN message?
>>>> 
>>>> y the way: Is the brokerName mandatory with a network of brokers
>>>> working 
>>>> with multicast?
>>>> 
>>>> 
>>>> 
>>>> 
>>> 
>>> HI!
>>> 
>>> Have you tried using defaultBroker as the brokername instead of the
>>> ${activemq.brokerName} u were using? 
>>> 
>>> hope that helps...
>>> 
>> 
>> 
>> 
>> Hi,
>> 
>> I got the same warning. The warning is generated by the discoveryagent,
>> when the connector ist started.
>> The discoveryagent is newly created, if it does not exist. The brokerName
>> property of the discoveryagent
>> is not set yet. The discoveryagent is started then and prints the
>> warning.
>> 
>> I think this is a bug, because if the agent is created from scratch, it
>> should be supplied with the brokername property of the connector for
>> which it is created.
>> 
>>  
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Starting-ActiveMQ%3A-brokerName-not-set--tf2613148.html#a7714553
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message