activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aditya_c ...@juventustech.com>
Subject Re: Problem with STOMP C++ Client connecting with a AMQ Broker having Authorization and Authentication Plugins installed
Date Sat, 02 Dec 2006 10:30:53 GMT

Hi Nate,

Just following up on Brian's [bhartsb] post below.

Would you be having some time to fix the build so that the "Broker sends an
ERROR msg and disconnects, instead  of sending a CONNECTED message first and
subsequently an ERROR in case a Client tries to connect using the wrong
credentials"?

We are stuck at this point with our development and would be grateful if you
could help us out here.

Alternatively if you are not able to find time now, could you guide me as to
where would I need to make the changes in the source code, so that I could
try and patch it.

Hoping for a reply.

Regards

Aditya Choudhuri






bhartsb wrote:
> 
> Hi Nate,
> 
> Thanks for making the changes.  However, it is still not quite working
> 100% as it should.  Right now when a connection is created using invalid
> credentials, the broker is sending back a CONNECTED msg first and then an
> ERROR msg.  The correct behaviour should be to send an ERROR msg and
> disconnect.  Not send CONNECTED first.
> 
> THis was also discussed in another thread and the behaviour agreed on was
> as I describe:
> 
> http://www.nabble.com/Proper-behavior-for-client-authorization-failure-tf2497200.html
> 
> Hopefully you can send another JAR soon.
> 
> Thanks again. 
> 
> nmittler wrote:
>> 
>> BTW, can you guys point me to the JIRA issue that has been created for
>> this?
>> 
>> Thanks,
>> Nate
>> 
>> On 11/11/06, Nathan Mittler <nathan.mittler@gmail.com> wrote:
>>>
>>> Ok guys,
>>> I've got a build that I'd like you to try:
>>>
>>> http://people.apache.org/~nmittler/<http://people.apache.org/%7Enmittler/>apache-activemq-4.2-incubator-SNAPSHOT.tar.gz
>>>
>>> <http://people.apache.org/%7Enmittler/apache-activemq-4.2-incubator-SNAPSHOT.tar.gz>.
>>>
>>>
>>> Let me know how it goes.
>>>
>>> Regards,
>>> Nate
>>>
>>> On 11/10/06, bhartsb <bhartsb@cox.net> wrote:
>>> >
>>> >
>>> >
>>> > Yes either Avinash or Aditya has previously opened a JIRA issue.  I
>>> > don't
>>> > know if anyone has claimed it however, nor an ETA.
>>> >
>>> > Thanks.
>>> >
>>> >
>>> > nmittler wrote:
>>> > >
>>> > > As far as I can tell, the activemq-cpp client should handle this
>>> > properly
>>> > > (
>>> > > i.e. throw an exception on receipt of a stomp error frame).
>>> > >
>>> > > It sounds like this problem has been brought up before - has a JIRA
>>> > issue
>>> > > been created?  If not, please create one, and I'll take a crack at
>>> it.
>>> >
>>> > >
>>> > > Thanks,
>>> > > Nate
>>> > >
>>> > > On 11/10/06, bhartsb <bhartsb@cox.net> wrote:
>>> > >>
>>> > >>
>>> > >> Hi I'll chime in here as this work discussed is being done for
me.
>>> > >>
>>> > >> First, you are correct that the CONNECTED msg is coming from the
>>> > >> broker...I
>>> > >> think that was just a typing error by my developer.
>>> > >>
>>> > >> As for the issue, the C++ call createConnection() creates a low
>>> level
>>> >
>>> > >> connection(assume), and passes credentials. Then the broker should
>>> > send a
>>> > >> STOMP ERROR msg back (if credentials are wrong) and disconnect.
 It
>>> > seems
>>> > >> this has already been discussed with regard to the RUBY client:
>>> > >>
>>> > >>
>>> > >>
>>> >
>>> http://www.nabble.com/Proper-behavior-for-client-authorization-failure-tf2497200.html
>>> > >>
>>> > >> If the C++ app. upon receiving ERROR then wants to create an
>>> > exception, I
>>> > >> suppose it could.
>>> > >>
>>> > >> Any ETA for this fix?
>>> > >>
>>> > >> Thanks.
>>> > >>
>>> > >> Hiram Chirino wrote:
>>> > >> >
>>> > >> > I'm thinking an ERROR should be sent back if an invalid CONNECT
>>> is
>>> > >> > given and then the connection should just get terminated.
>>> > >> >
>>> > >> > On 11/8/06, Timothy Bish <tabish@twcny.rr.com> wrote:
>>> > >> >>
>>> > >> >> >
>>> > >> >> > Thanks for your reply.
>>> > >> >> >
>>> > >> >> > We are not getting any errors when we are trying
to
>>> send/receive
>>> > >> >> message.
>>> > >> >> >
>>> > >> >> > What we require here is that, when we are sending
wrong
>>> > credentials
>>> > >> to
>>> > >> >> the
>>> > >> >> > AMQ Broker, the C++ ActiveMQ client should be able
to get the
>>> > >> >> > Authentication
>>> > >> >> > failed error code.
>>> > >> >>
>>> > >> >> Right we get that, we just wanted to know how much functionality
>>> > the
>>> > >> >> stomp
>>> > >> >> client had when connected with bad credentials.  Sounds
like
>>> none
>>> > is
>>> > >> what
>>> > >> >> you're seeing.
>>> > >> >>
>>> > >> >> >
>>> > >> >> > The 'CONNECTED' message is not being sent by AMQ
Broker at
>>> all,
>>> > as
>>> > >> the
>>> > >> >> > plug-in is installed in the Broker.
>>> > >> >> >
>>> > >> >> > This 'CONNECTED' message we are receiving in the
>>> > >> SocketInputStream.cpp
>>> > >> >> > class
>>> > >> >> > present under C++ ActiveMQ client.
>>> > >> >>
>>> > >> >> The connected message would have to be coming from the
Broker as
>>> > the
>>> > >> CPP
>>> > >> >> client wouldn't spuriously create one for you.  We are
looking
>>> > into
>>> > >> what
>>> > >> >> the
>>> > >> >> correct behavior should be given the limitations of the
stomp
>>> > >> protocol.
>>> > >> >>
>>> > >> >> We'll keep you posted on the fix.
>>> > >> >>
>>> > >> >> Regards
>>> > >> >> Tim
>>> > >> >>
>>> > >> >>
>>> > >> >>
>>> > >> >>
>>> > >> >
>>> > >> >
>>> > >> > --
>>> > >> > Regards,
>>> > >> > Hiram
>>> > >> >
>>> > >> > Blog: http://hiramchirino.com
>>> > >> >
>>> > >> >
>>> > >>
>>> > >> --
>>> > >> View this message in context:
>>> > >>
>>> http://www.nabble.com/Problem-with-STOMP-C%2B%2B-Client-connecting-with-a-AMQ-Broker-having-Authorization-and-Authentication-Plugins-installed-tf2582789.html#a7274843
>>> >
>>> > >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>> > >>
>>> > >>
>>> > >
>>> > >
>>> >
>>> > --
>>> > View this message in context:
>>> >
>>> http://www.nabble.com/Problem-with-STOMP-C%2B%2B-Client-connecting-with-a-AMQ-Broker-having-Authorization-and-Authentication-Plugins-installed-tf2582789.html#a7284666
>>> > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>> >
>>> >
>>>
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-with-STOMP-C%2B%2B-Client-connecting-with-a-AMQ-Broker-having-Authorization-and-Authentication-Plugins-installed-tf2582789.html#a7652115
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message