activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: Address already in use exception
Date Fri, 29 Dec 2006 13:09:43 GMT
could you raise an issue - with test case here please: http:// 
issues.apache.org/activemq/secure/CreateIssue!default.jspa
and fill in as much info as you can (version, operating system etc)

cheers,

Rob
On 29 Dec 2006, at 12:04, mladzo wrote:

>
> While starting my Spring application i'm getting exception (i also  
> changed
> port number to 61617 (also tried with 61618), but but i still get same
> exception):
>
> Allocate exception for servlet action
> org.springframework.beans.factory.BeanCreationException: Error  
> creating bean
> with name 'serverTransport' defined in class path resource  
> [activemq.xml]:
> Instantiation of bean failed; nested exception is
> org.springframework.beans.factory.BeanDefinitionStoreException:  
> Factory
> method [public static org.activemq.transport.TransportServerChannel
> org.activemq.transport.TransportServerChannelProvider.newInstance 
> (org.activemq.io.WireFormat,java.lang.String)
> throws javax.jms.JMSException,java.net.URISyntaxException] threw  
> exception;
> nested exception is javax.jms.JMSException: Bind to tcp://localhost: 
> 61616
> failed: Address already in use: JVM_Bind
> org.springframework.beans.factory.BeanDefinitionStoreException:  
> Factory
> method [public static org.activemq.transport.TransportServerChannel
> org.activemq.transport.TransportServerChannelProvider.newInstance 
> (org.activemq.io.WireFormat,java.lang.String)
> throws javax.jms.JMSException,java.net.URISyntaxException] threw  
> exception;
> nested exception is javax.jms.JMSException: Bind to tcp://localhost: 
> 8081
> failed: Address already in use: JVM_Bind
> javax.jms.JMSException: Bind to tcp://localhost:8081 failed:  
> Address already
> in use: JVM_Bind
> 	at
> org.activemq.util.JMSExceptionHelper.newJMSException 
> (JMSExceptionHelper.java:49)
> 	at
> org.activemq.transport.tcp.TcpTransportServerChannel.<init> 
> (TcpTransportServerChannel.java:79)
> 	at
> org.activemq.transport.tcp.TcpTransportServerChannelFactory.create 
> (TcpTransportServerChannelFactory.java:43)
> 	at
> org.activemq.transport.TransportServerChannelProvider.create 
> (TransportServerChannelProvider.java:45)
> 	at
> org.activemq.transport.TransportServerChannelProvider.newInstance 
> (TransportServerChannelProvider.java:56)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at
> sun.reflect.NativeMethodAccessorImpl.invoke 
> (NativeMethodAccessorImpl.java:39)
> 	at
> sun.reflect.DelegatingMethodAccessorImpl.invoke 
> (DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:585)
>
> Anyone knows where there is the problem?
> -- 
> View this message in context: http://www.nabble.com/Address-already- 
> in-use-exception-tf2894353.html#a8086540
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message