activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Consumer connected and started, but onMessage never invoked
Date Tue, 21 Nov 2006 17:35:36 GMT
Are you calling start() on the Connection? Its a common gotcha that I
keep hitting...

http://incubator.apache.org/activemq/i-am-not-receiving-any-messages-what-is-wrong.html

BTW you might wanna ping the Compass folks, particularly Shay who have
been pondering similar things - distributing Lucene indexes across a
cluster etc.

http://www.opensymphony.com/compass/

On 11/16/06, rhodebump <spamsucks@rhoderunner.com> wrote:
>
> Hi everyone,
> I am trying to using spring 2.0, activemq 4.1 snapshot and lucene in an
> exciting open source project that I will soon be releasing.  I am using
> activemq to keep lucene indexes up to date in a distributed environment.  My
> idea is that a change to the data will publish a "data is changed" type of
> message to a topic.  Multiple consumers subscribing to the topic will
> receive this message and update the lucene index that they maintain.
>
> I have a broker running that I can connect to via JMX and see that there are
> messages on my topic (org.apache.activemq.spring.Test.spring.topic)
>
> Feel free to look yourself, hostname is test.rhoderunner.com port is 6969
>
> I have a consumer that is successfully connecting to this same broker.
> However, the "onMessage" method never gets invoked.  I do call the "start"
> method in my Consumer successfully
>
> http://www.nabble.com/file/4192/IndexerListener.java IndexerListener.java
>
> http://www.nabble.com/file/4193/indexerContext.xml indexerContext.xml
>
> From my understanding, starting the consumer will connect to my topic and
> process the messages that are on the topic.  The topic name that I am using
> (matches on both sides) is org.apache.activemq.spring.Test.spring.topic
>
> Does anyone see a mistake in my understanding of things?  Would anyone be
> interested in contributing towards this project?
>
> Phillip
>
>
>
>
> --
> View this message in context: http://www.nabble.com/Consumer-connected-and-started%2C-but-onMessage-never-invoked-tf2644659.html#a7382745
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message