activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Invalid version: 2, could not load org.apache.activemq.openwire.v2.MarshallerFactory
Date Thu, 09 Nov 2006 13:08:38 GMT
Which version are you using? Its working fine for 4.1-SNAPSHOT and trunk of svn

On 11/8/06, robottaway <rottaway@musiciansfriend.com> wrote:
>
> This is also a problem for me when connecting from the .NET Openwire API:
>
> Exception in thread "ActiveMQ Transport: tcp:///172.16.11.229:2497"
> java.lang.IllegalArgumentException: Invalid version: 2, could not load
> org.apache.activemq.openwire.v2.MarshallerFactory
>         at
> org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:329)
>         at
> org.apache.activemq.openwire.OpenWireFormat.renegociatWireFormat(OpenWireFormat.java:569)
>         at
> org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:100)
>         at
> org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:122)
>         at
> org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:87)
>         at
> org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:143)
>         at java.lang.Thread.run(Thread.java:613)
> Caused by: java.lang.ClassNotFoundException:
> org.apache.activemq.openwire.v2.MarshallerFactory
>         at
> org.apache.activemq.util.ClassLoading.loadClass(ClassLoading.java:104)
>         at
> org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:327)
>         ... 6 more
> --
> View this message in context: http://www.nabble.com/Invalid-version%3A-2%2C-could-not-load-org.apache.activemq.openwire.v2.MarshallerFactory-tf2589891.html#a7248045
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message