activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Mittler" <nathan.mitt...@gmail.com>
Subject Re: receiving async exception when not appropriate
Date Sun, 12 Nov 2006 14:16:42 GMT
After reading your JIRA issue a little closer, it looks like this is a
different problem ...  so don't bother testing out that buid.

What exactly do you expect to happen when you send to a queue that you're
not authorized to send on?  I don't think it's acceptable to throw an
exception from within the send() method, because that would require waiting
for the broker to respond to the message before proceeding - essentially
making the model RPC rather than messaging.

So if you don't want to lose the data in the message, you'll have to know
what destinations you have write permissions on before sending.

Does this make sense?

Regards,
Nate

On 11/12/06, Nathan Mittler <nathan.mittler@gmail.com> wrote:
>
> Hi,
> Appologies that no one has responded - the AMQ developer community is a
> busy bunch and as a result, an occasional e-mail gets dropped in the shuffle
> :(.
>
> The good news is that others have been raising this problem as well.  I
> took a crack at a fix from the latest trunk build (as of yesterday).  The
> tarball is here:
>
> http://people.apache.org/~nmittler/<http://people.apache.org/%7Enmittler/>apache-activemq-4.2-incubator-SNAPSHOT.tar.gz
>
> <http://people.apache.org/%7Enmittler/apache-activemq-4.2-incubator-SNAPSHOT.tar.gz>
>
> Please give it a try and let me know how it goes.
>
> Thanks,
> Nate
>
> On 11/12/06, massive.boisson <massive.boisson@gmail.com> wrote:
> >
> >
> > Dear good people of ActiveMQ, I am begging you for any comment on this
> > problem. It's been 2 weeks since I raised JIRA  (
> > https://issues.apache.org/activemq/browse/AMQ-1022
> > https://issues.apache.org/activemq/browse/AMQ-1022 ).
> >
> > Any thoughts?
> >
> > Thanks,
> >
> > --MB
> >
> >
> > massive.boisson wrote:
> > >
> > > Hi All,
> > >
> > > can somebody please comment on this.
> > > Am I getting something wrong (ie this is working as it should) or is
> > this
> > > a real problem?
> > >
> > > Please, somebody let me know,
> > >
> > > Thanks
> > >
> > > --MB
> > >
> > >
> > >
> > >
> > > massive.boisson wrote:
> > >>
> > >> I have raised an JIRA issue for this -
> > >> http://issues.apache.org/activemq/browse/AMQ-1022 .
> > >> I think this is a real problem.
> > >>
> > >> I can provide more information for whoever is interested in this, for
> > >> example the tests that I used, activemq.xml file.....
> > >>
> > >> --MB
> > >>
> > >>
> > >>
> > >>
> > >> massive.boisson wrote:
> > >>>
> > >>> I tried to test this with ActiveMQ 4.0.1 and regular security
> > settings
> > >>> as per page: http://incubator.apache.org/activemq/security.html, and
> > I
> > >>> received the same results as in previous attempt - I receive asynch
> > >>> exception after send executes without exception as if message has
> > been
> > >>> indeed sent.
> > >>>
> > >>> Any ideas what's going on?
> > >>>
> > >>> --MB
> > >>>
> > >>>
> > >>
> > >>
> > >
> > >
> >
> > --
> > View this message in context:
> > http://www.nabble.com/receiving-async-exception-when-not-appropriate-tf2545596.html#a7301211
> > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message