activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mittler, Nathan" <nathan.mitt...@sensis.com>
Subject RE: Problem with STOMP C++ Client connecting with a AMQ Broker having Authorization and Authentication Plugins installed
Date Tue, 07 Nov 2006 15:16:23 GMT
After you get the 'CONNECTED' back, can you successfully send/receive
messages?

-----Original Message-----
From: Bish, Tim [mailto:Tim.Bish@Sensis.com] 
Sent: Monday, November 06, 2006 10:10 AM
To: activemq-users@geronimo.apache.org
Subject: RE: Problem with STOMP C++ Client connecting with a AMQ Broker
having Authorization and Authentication Plugins installed


> [1] When connecting using the STOMP client with incorrect credentials,
the
> AMQ Broker throws SecurityException [which is expected], however the
STOMP
> client receives a message 'CONNECTED'
> 
> [2] The STOMP client does not get notified that there was a 
> SecurityException while connecting [when connecting using wrong 
> credentials].
> 
> 
> 
> Questions are:
> 
> [1] Why does the program execution not proceed in case of CASE 2 ?
> 
> [2] How does the C++ STOMP client get notified of any Authentication
or
> Authorization exceptions that may be generated at the AMQ Broker end ?
> 

Sounds like the broker is not handling this case correctly, the STOMP
client can't handle this unless told by the broker, which apparently
isn't implemented or working correctly.  

Please create a Jira Issue against the broker documenting this issue.

http://issues.apache.org/activemq/browse/AMQ

Regards
Tim


Mime
View raw message