activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javaman <junkkaddr...@yahoo.com>
Subject Problem setting up AjaxServlet
Date Tue, 28 Nov 2006 19:23:14 GMT

I wasn't sure where to put the jars for ActiveMQ or which jar is the
AjaxServlet, so I just put them all in the WEB-INF/classes/ of my app.  Even
so, I still get the following error.  Can anyone help me figure out where to
put the jars or just explain how to set up this servlet.

HTTP Status 500 - 

--------------------------------------------------------------------------------

type Exception report

message 

description The server encountered an internal error () that prevented it
from fulfilling this request.

exception 

javax.servlet.ServletException: Wrapper cannot find servlet class
org.apache.activemq.web.AjaxServlet or a class it depends on

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:868)

org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:663)

org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)

org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
	java.lang.Thread.run(Thread.java:595)


root cause 

java.lang.ClassNotFoundException: org.apache.activemq.web.AjaxServlet

org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1338)

org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1187)

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:868)

org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:663)

org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)

org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
	java.lang.Thread.run(Thread.java:595)


note The full stack trace of the root cause is available in the Apache
Tomcat/5.5.12 logs.


--------------------------------------------------------------------------------

Apache Tomcat/5.5.12
-- 
View this message in context: http://www.nabble.com/Problem-setting-up-AjaxServlet-tf2720376.html#a7585790
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message