activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marlon Santos <msan...@exist.com>
Subject Re: Advisory Message support in Multi - Broker environment
Date Thu, 23 Nov 2006 04:53:13 GMT

Hi,

I tried your case but it works fine on me. Can you upload your code/config
so i can look into it as to where the problem was originating.

Regards,
Marlon



Rohit Bahl wrote:
> 
> I have a multi broker environment. i.e. 
> MessageProducer application connected to Broker1 and
> MessageConsumer application connected to Broker2
> I have enabled multicast between the two brokers.
> MessageProducer writes to a queue and MessageConsumer reads from the
> queue.
> 
> I see messages appearing in MessageConsumer application when I post an
> message from the MessageProducer application
> 
> In the MessageProducer application I also have a consumer to the
> destination ActiveMQ.Advisory.Consumer.Queue.
> I use this listener to detect if a consumer is connected or gets
> disconnected.
> 
> What I have observed is that I received the consumer advisory message when
> a consumer connects, but
> I do not receive an message when the consumer disconnects.
> 
> However, if I use a single broker for the MessageProducer and
> MessageConsumer 
> I get the message when the consumer disconnects.
> 
> Kindly help.
> 

-- 
View this message in context: http://www.nabble.com/Advisory-Message-support-in-Multi---Broker-environment-tf2631016.html#a7500816
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message