activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ricardo <dickvos...@gmail.com>
Subject Re: Can't use Hermes JMS with the last ActiveMQ 4.2 SNAPSHOT
Date Thu, 16 Nov 2006 11:09:01 GMT

Yes, I tried to delete persistence files in every try it but I'm seeing the
same error.

Rhodebump, the jars I'm using are:

activeio-core-3.x-incubator-20061027.143938-1.jar
activemq-core-4.2-incubator-20061110.043035-46.jar
backport-util-concurrent-2.1.jar
commons-logging-1.0.4.jar
geronimo-j2ee-management_1.0_spec-1.0.jar
geronimo-jms_1.1_spec-1.0.jar
spring-2.0.jar (final)
xbean-spring-2.7-SNAPSHOT.jar 


James.Strachan wrote:
> 
> I wonder, did you try clearing out the persistence files betfore
> upgrading the activemq jars?
> 
> On 11/16/06, rhodebump <spamsucks@rhoderunner.com> wrote:
>>
>>
>> Ricardo,
>> I am having this same issue with the latest 4.1 snapshots.  I am also
>> using
>> spring 2.0/xbean-spring.
>> Let's work together and share info and try to fix this problem.
>>
>> I have activemq running on a public server that folks can try (feel free)
>> hostname: test.rhoderunner.com
>> port: 6969
>>
>> jars:
>> activeio-core-3.x-incubator-20061027.143938-1.jar
>> activemq-core-4.1-incubator-20061110.043035-46.jar
>> backport-util-concurrent-2.1.jar
>> commons-logging-1.0.4.jar
>> geronimo-j2ee-management_1.0_spec-1.0.jar
>> geronimo-jms_1.1_spec-1.0.jar
>> spring-2.0-rc1.jar
>> xbean-spring-2.6.jar
>>
>> <beans xmlns="http://www.springframework.org/schema/beans"
>> xmlns:amq="http://activemq.org/config/1.0"
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.springframework.org/schema/beans
>> http://www.springframework.org/schema/beans/spring-beans.xsd
>>   http://activemq.org/config/1.0
>> http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd">
>>
>>   <!--  lets create an embedded ActiveMQ Broker -->
>>   <amq:broker useJmx="true" persistent="false" brokerName="BROKER_1">
>>     <amq:transportConnectors>
>>       <amq:transportConnector uri="tcp://localhost:6969" />
>>     </amq:transportConnectors>
>>   </amq:broker>
>>
>> </beans>
>>
>>
>>
>> Ricardo wrote:
>> >
>> > Hello,
>> >
>> > I was using one of the first 4.1 snapshots and it worked fine with
>> Hermes
>> > but now I have a problem with the wire format. After updating spring to
>> > 2.0, I had to use a newer snapshot with the new version of
>> xbean-spring.
>> > I'm trying to use Hermes but it doesn't work in the last 4.1 and 4.2
>> > snapshots. I use the same Hermes configuration as always, topic
>> > discoverment works fine but when I try to browse a topic or queue
>> Hermes
>> > throws this message:
>> >
>> > javax.jms.JMSException
>> >
>> > Wire format negotation timeout : peer did not send his wire format.
>> >
>> > I'll upload a file with our log showing the wire negotiation. I hope to
>> > not to annoy anyone with a dummy question, I don't have so much
>> experience
>> > with ActiveMQ.
>> >
>> > Thanks in advance,
>> >
>> > Ricardo. http://www.nabble.com/file/4179/log.xml log.xml
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Can%27t-use-Hermes-JMS-with-the-last-ActiveMQ-4.2-SNAPSHOT-tf2636010.html#a7371755
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/Can%27t-use-Hermes-JMS-with-the-last-ActiveMQ-4.2-SNAPSHOT-tf2636010.html#a7375671
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message