activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wpen <william.penno...@danet.de>
Subject Re: iptables configuration changes needed for activemq
Date Fri, 10 Nov 2006 22:09:00 GMT



Adrian Co wrote:
> 
> You might want to reconfigure JMX also. I think it might open a port to 
> 1099 by default..
> 
> James Strachan wrote:
>> On 10/31/06, wpen <william.pennoyer@danet.de> wrote:
>>> Hello,
>>> I would like to run activemq behind a firewall with only one transport
>>> connector setup for tcp on port 61616. Is 61616 the only port which 
>>> needs to
>>> be opened?
>>
>> Yes - you can use any port you like.
>>
>>> Also, would you know or know where I could find the proper iptables 
>>> entries
>>> to accomplish the above?
>>
>> Just edit the activemq.xml to use whatever port you wish.
>>
> 
> 
> 


Thank you both for your help. Activemq was up and running on the first try.
As you said, the only thing we needed to do was open one for tcp. That we
did, however, only after completely locking ourselves once before finally
getting it right. In the end, we didn't have to work directly with the
iptable entries because the the server has SuSE 10 as an OS which meant we
only needed to add the port number to the existing FW_SERVICES_EXT_TCP entry
in the SuSEfirewall2 script.
 

-- 
View this message in context: http://www.nabble.com/iptables-configuration-changes-needed-for-activemq-tf2548986.html#a7286133
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message