activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robottaway <rotta...@musiciansfriend.com>
Subject networkConnectors causing NPE
Date Wed, 08 Nov 2006 21:39:34 GMT

I get a null pointer exception from the parsing of the XBean file
(activemq.xml) when I try to configure a 'networkConnector' element under
'networkConnectors'. I am using 4.0.2.

ACTIVEMQ_HOME:
/opt/MFApps/ServiceMix/activemq_installs/incubator-activemq-4.0.2
Loading message broker from: xbean:activemq.xml
ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'org.apache.activemq.xbean.XBeanBrokerService' defined in class
path resource [activemq.xml]: Error setting property values; nested
exception is org.springframework.beans.PropertyAccessExceptionsException:
PropertyAccessExceptionsException (1 errors); nested
propertyAccessExceptions are:
[org.springframework.beans.MethodInvocationException: Property
'networkConnectors' threw exception; nested exception is
java.lang.NullPointerException: null]
ERROR: java.lang.Exception:
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'org.apache.activemq.xbean.XBeanBrokerService' defined in class
path resource [activemq.xml]: Error setting property values; nested
exception is org.springframework.beans.PropertyAccessExceptionsException:
PropertyAccessExceptionsException (1 errors); nested
propertyAccessExceptions are:
[org.springframework.beans.MethodInvocationException: Property
'networkConnectors' threw exception; nested exception is
java.lang.NullPointerException: null]
-- 
View this message in context: http://www.nabble.com/networkConnectors-causing-NPE-tf2598042.html#a7247527
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message