activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Avinash <>
Subject RE: Problem with STOMP C++ Client connecting with a AMQ Broker having Authorization and Authentication Plugins installed
Date Wed, 08 Nov 2006 14:39:56 GMT

Hi Timothy,

Thanks for your reply.

We are not getting any errors when we are trying to send/receive message. 

What we require here is that, when we are sending wrong credentials to the
AMQ Broker, the C++ ActiveMQ client should be able to get the Authentication
failed error code.

The 'CONNECTED' message is not being sent by AMQ Broker at all, as the
plug-in is installed in the Broker.

This 'CONNECTED' message we are receiving in the SocketInputStream.cpp class
present under C++ ActiveMQ client.

The message we are getting, though the credentials(username and password)
that are passed to AMQ Broker Authentication plug-in, for Authentication.

Thanks in advance.


Timothy Bish wrote:
>> We are getting 'CONNECTED' message, after making a connection with AMQ
>> Broker, though the credentials are correct or wrong, and not able to
>> send/receive messages.
> Do you get any errors when you try and send something after getting
> connected?  I think Nate is trying to characterize the behavior a bit to
> help with debugging the broker.  
>> To send/receive messages, the credentials are required to go through the
>> Authenticatoin and Auithorizatin plug-in.
>> Mittler, Nathan wrote:
>> >
>> > After you get the 'CONNECTED' back, can you successfully send/receive
>> > messages?
>> >

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message