activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Joschko <markus.josc...@gmail.com>
Subject Possible error in activemq-core-4.1-incubator-SNAPSHOT.xsd?
Date Thu, 26 Oct 2006 14:48:42 GMT

Hi all,
after I could get hold of xbeans-spring 2.7 I tried to pimp up my broker but
as soon as I include the <amq:broker> tag I get a schema error
My applicationContext looks like:

<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	   xmlns:amq="http://activemq.org/config/1.0"
       xmlns:util="http://www.springframework.org/schema/util"
       xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
						   http://www.springframework.org/schema/util
http://www.springframework.org/schema/util/spring-util-2.0.xsd
						   http://activemq.org/config/1.0
http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd">
						   
	<amq:broker useJmx="false" persistent="false">
		<amq:transportConnectors>
			<amq:transportConnector uri="vm://localhost"/>	
		</amq:transportConnectors>	
	</amq:broker>  

.......


As soon as the context gets loaded I get the following exception:
java.lang.ExceptionInInitializerError
Caused by: org.springframework.beans.factory.BeanDefinitionStoreException:
Line 224 in XML document from class path resource
[com/test/core/context/applicationContext.xml] is invalid; nested exception
is org.xml.sax.SAXParseException: s4s-att-invalid-value: Invalid attribute
value for 'type' in element 'attribute'. Recorded reason: UndeclaredPrefix:
Cannot resolve 'xsd:string' as a QName: the prefix 'xsd' is not declared.
	at
org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:417)
	at ....

If I remove the amq:broker tag from the file, everything works fine.
Could it be that the wild mixing between xsd:string and xs:string is causing
problems? I have very little xsd knowhow so that's only a guess.

Regards,
 Markus
-- 
View this message in context: http://www.nabble.com/Possible-error-in-activemq-core-4.1-incubator-SNAPSHOT.xsd--tf2514388.html#a7012556
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message