activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From igah <weiqi...@mail.com>
Subject Re: incorrect DequeueCount?
Date Tue, 24 Oct 2006 13:27:43 GMT

more info, when i shutdown my consumers, i see stats like this during one
test:

Type = Queue
Destination = XXX
QueueSize = 948
Name = XXX
DequeueCount = 4224
ConsumerCount = 0
EnqueueCount = 2722

why is DequeueCount greater than EnqueueCount? (the activemq instance was
started from a clean database and journal)



igah wrote:
> 
> i am seeing this through activemq (4.0.1) jmx:
> 
> Type = Queue
> Destination = XXX
> QueueSize = 2751
> Name = XXX
> DequeueCount = 3575
> MemoryPercentageUsed = 0
> ConsumerCount = 6
> MemoryLimit = 9223372036854775807
> EnqueueCount = 3575
> 
> and after a while, something like this:
> 
> Destination = XXX
> QueueSize = 11421
> Name = XXX
> DequeueCount = 8046
> MemoryPercentageUsed = 0
> ConsumerCount = 6
> MemoryLimit = 9223372036854775807
> EnqueueCount = 13471
> 
> my activemq is started with a clean database and journal. how does the
> math add up among QueueSize, DequeueCount and EnqueueCount? i thought
> dequeuecount + queuesize = enqueuecount. in my case, QueueSize looks more
> "correct" than the dequeuecount is wrong because my consumers are slower
> than message producers.
> 
> thanks in advance. 
> 
>  
> 

-- 
View this message in context: http://www.nabble.com/incorrect-DequeueCount--tf2497713.html#a6972714
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message