activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rkrol <>
Subject MDB Transaction problem
Date Thu, 19 Oct 2006 13:22:17 GMT


I have some problems with my MDB that I want to use to transfer messages
from queue "question" to queue "reponse".

The MDB works fine if there is only one message on the queue "question" :
 - the message is received
 - a message is sent on "reponse"
 - transaction is commited

The problem appears when the queue "question" contains more than one message
 - the first message is received
 - the message on "reponse" is sent
 - transaction is not committed, and goes on time-out
             => first message is still in queue "question"
             => the next messages are not treated

Here is my configuration :
 - ActiveMQ 4.1 SNAPSHOT executed in standalone mode
 - a Ressource Adapter deployed on JOnAS 4.6.6
 - a MDB deployed on the same JOnAS that use the JNDI names specified in the
RA for ActiveMQ ConnexionFactory and Queues
 - the configuration files :
               * activemq.xml 
               * ejb-jar.xml 
               * jonas-ra.xml 
               * ra.xml 
 - the MDB code : 

I think the problem concerns the ActiveMQ configuration about the
acknowledge management, because the same code works with JORAM...
I've tried to 
 - disable the optimizeAcknowledge in the URL property of the "ra.xml" (ex:
 - configure the prefetch size to 1 in the URL property of the "ra.xml" (ex:
 - add the autoAcknowledge mode in ActivationSpec that is, I think, the
default mode
but these solutions don't resolve the problem...

Thanks in advance for any help.

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message