activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kristoffer <sto...@gmail.com>
Subject Re: Client hangs in MulticastDiscoveryAgent
Date Thu, 19 Oct 2006 11:28:18 GMT

Hmmm, yes it seems as if this has nothing to do with the brokername? Even
though i find it strange that it is never set (i guess you can see this from
the log also: default.ActiveMQ-4.alive.%null%tcp://artimus:16161)

I have completly removed my firewall so that im certain that nothing is
blocking datagram packet. I wonder, has this something to do with that i run
broker and client on the same machine? Seems a bit strange?

regards,
-Kristoffer



gnodet wrote:
> 
> I already had this exception when my connection goes down.
> 
> On 10/19/06, kristoffer <stoffe@gmail.com> wrote:
>>
>> Hi again,
>>
>> After some minutes an exception was thrown in the broker:
>>
>> 2006-okt-19 12:32:13
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent
>> doAdvertizeSelf
>> ALLVARLIG: Failed to advertise our service:
>> default.ActiveMQ-4.alive.%null%tcp://artimus:16161
>> java.net.NoRouteToHostException: No route to host: Datagram send failed
>>         at java.net.PlainDatagramSocketImpl.send(Native Method)
>>         at java.net.DatagramSocket.send(Unknown Source)
>>         at
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent.doAdvertizeSelf(MulticastDiscoveryAgent.java:311)
>>         at
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent.doTimeKeepingServices(MulticastDiscoveryAgent.java:295)
>>         at
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent.run(MulticastDiscoveryAgent.java:253)
>>         at java.lang.Thread.run(Unknown Source)
>>
>> Does this make any more sense?
>>
>> Thanks,
>> -Kristoffer
>>
>>
>> kristoffer wrote:
>> >
>> > Hi,
>> >
>> > incubator-activemq-4.0.2.jar
>> >
>> > I have successfully set up static tcp communication between clients and
>> a
>> > broker, Yeah! But when i try to move to multicast in order to discover
>> my
>> > brokers from the clients i get in trouble..
>> >
>> > I keep getting warning messages (on broker and client) like:
>> >
>> >
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent
>> > start
>> > WARNING: brokerName not set
>> >
>> > I read an earlier thread that explained that brokerName should be set
>> like
>> > an valid URI, but that did not work for me. (i know the brokerName is
>> > currently not a valid URI, i took this from the testcases so it should
>> > work?)
>> >
>> > Here is my activemq.xml
>> >
>> > <beans xmlns="http://activemq.org/config/1.0">
>> >   <broker useJmx="false" brokerName="BrokerA">
>> >
>> >     <persistenceAdapter>
>> >       <journaledJDBC journalLogFiles="5"
>> > dataDirectory="activemq-broker-data"/>
>> >     </persistenceAdapter>
>> >
>> >     <transportConnectors>
>> >        <transportConnector name="default" uri="tcp://localhost:61616"
>> > discoveryUri="multicast://224.1.2.3:6155"/>
>> >     </transportConnectors>
>> >
>> >     <networkConnectors>
>> >       <networkConnector name="default"
>> uri="multicast://224.1.2.3:6155"/>
>> >     </networkConnectors>
>> >
>> >   </broker>
>> > </beans>
>> >
>> > On the client i create my URI like so:
>> > discovery:multicast://224.1.2.3:6155
>> >
>> > When i fire up my client i get this 'broker not set' message but then
>> it
>> > just hangs..? Here's a thread dump from that hanging:
>> >
>> > Full thread dump Java HotSpot(TM) Client VM (1.5.0_09-b01 mixed mode,
>> > sharing):
>> >
>> > "MulticastDiscovery: null" daemon prio=6 tid=0x00acbe78 nid=0x5e0
>> runnable
>> > [0x02edf000..0x02edfbe8]
>> >         at java.net.PlainDatagramSocketImpl.receive0(Native Method)
>> >         - locked <0x22aea588> (a java.net.PlainDatagramSocketImpl)
>> >         at java.net.PlainDatagramSocketImpl.receive(Unknown Source)
>> >         - locked <0x22aea588> (a java.net.PlainDatagramSocketImpl)
>> >         at java.net.DatagramSocket.receive(Unknown Source)
>> >         - locked <0x22af9c58> (a java.net.DatagramPacket)
>> >         - locked <0x22aea138> (a java.net.MulticastSocket)
>> >         at
>> >
>> org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent.run(MulticastDiscoveryAgent.java:255)
>> >         at java.lang.Thread.run(Unknown Source)
>> >
>> > "Low Memory Detector" daemon prio=6 tid=0x00a72030 nid=0x708 runnable
>> > [0x00000000..0x00000000]
>> >
>> > "CompilerThread0" daemon prio=10 tid=0x00a70ad0 nid=0xfc waiting on
>> > condition [0x00000000..0x02c0f748]
>> >
>> > "Signal Dispatcher" daemon prio=10 tid=0x00a6fdc0 nid=0x1e0 waiting on
>> > condition [0x00000000..0x00000000]
>> >
>> > "Finalizer" daemon prio=8 tid=0x00a42958 nid=0x4fc in Object.wait()
>> > [0x02b8f000..0x02b8f9e8]
>> >         at java.lang.Object.wait(Native Method)
>> >         - waiting on <0x22fc39a8> (a java.lang.ref.ReferenceQueue$Lock)
>> >         at java.lang.ref.ReferenceQueue.remove(Unknown Source)
>> >         - locked <0x22fc39a8> (a java.lang.ref.ReferenceQueue$Lock)
>> >         at java.lang.ref.ReferenceQueue.remove(Unknown Source)
>> >         at java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)
>> >
>> > "Reference Handler" daemon prio=10 tid=0x0003fb30 nid=0x700 in
>> > Object.wait() [0x02b4f000..0x02b4fae8]
>> >         at java.lang.Object.wait(Native Method)
>> >         - waiting on <0x22fc3a28> (a java.lang.ref.Reference$Lock)
>> >         at java.lang.Object.wait(Unknown Source)
>> >         at java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)
>> >         - locked <0x22fc3a28> (a java.lang.ref.Reference$Lock)
>> >
>> > "main" prio=6 tid=0x00036b88 nid=0xd08 in Object.wait()
>> > [0x0007f000..0x0007fc3c]
>> >         at java.lang.Object.wait(Native Method)
>> >         - waiting on <0x22b557d0> (a java.lang.Object)
>> >         at
>> >
>> org.apache.activemq.transport.failover.FailoverTransport.oneway(FailoverTransport.java:352)
>> >         - locked <0x22b557d0> (a java.lang.Object)
>> >         at
>> >
>> org.apache.activemq.transport.TransportFilter.oneway(TransportFilter.java:82)
>> >         at
>> >
>> org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:45)
>> >         - locked <0x22b536d0> (a java.lang.Object)
>> >         at
>> >
>> org.apache.activemq.transport.ResponseCorrelator.asyncRequest(ResponseCorrelator.java:67)
>> >         at
>> >
>> org.apache.activemq.transport.ResponseCorrelator.request(ResponseCorrelator.java:72)
>> >         at
>> >
>> org.apache.activemq.ActiveMQConnection.syncSendPacket(ActiveMQConnection.java:1115)
>> >         at
>> >
>> org.apache.activemq.ActiveMQConnection.ensureConnectionInfoSent(ActiveMQConnection.java:1203)
>> >         - locked <0x22ad11d0> (a
>> org.apache.activemq.ActiveMQConnection)
>> >         at
>> >
>> org.apache.activemq.ActiveMQConnection.start(ActiveMQConnection.java:435)
>> >         at
>> >
>> org.logicblaze.lingo.jms.JmsProducerConfig.createConnection(JmsProducerConfig.java:85)
>> >         at
>> >
>> org.logicblaze.lingo.jms.impl.MultiplexingRequestor.newInstance(MultiplexingRequestor.java:65)
>> >         at
>> >
>> org.logicblaze.lingo.jms.JmsServiceExporterMessageListener.afterPropertiesSet(JmsServiceExporterMessageListener.java:84)
>> >         at
>> >
>> org.logicblaze.lingo.jms.JmsServiceExporter.afterPropertiesSet(JmsServiceExporter.java:47)
>> >         at
>> >
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1091)
>> >         at
>> >
>> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:396)
>> >         at
>> >
>> org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:233)
>> >         - locked <0x23007b60> (a java.util.HashMap)
>> >         at
>> >
>> org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:145)
>> >         at
>> >
>> org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:283)
>> >         at
>> >
>> org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:313)
>> >         at
>> >
>> org.springframework.context.support.FileSystemXmlApplicationContext.<init>(FileSystemXmlApplicationContext.java:89)
>> >         at
>> >
>> org.springframework.context.support.FileSystemXmlApplicationContext.<init>(FileSystemXmlApplicationContext.java:74)
>> >         at
>> >
>> org.springframework.context.support.FileSystemXmlApplicationContext.<init>(FileSystemXmlApplicationContext.java:65)
>> >         at
>> > se.ericsson.consumer.test.ConsumerTest.main(ConsumerTest.java:12)
>> >
>> > "VM Thread" prio=10 tid=0x00a40ae8 nid=0xe1c runnable
>> >
>> > "VM Periodic Task Thread" prio=10 tid=0x00a6f9a8 nid=0xc4c waiting on
>> > condition
>> >
>> > I have tried to set the muticast URI to multicast://default as
>> suggested
>> > in many examples but it gives me the same error. Could this have
>> something
>> > to do with my network? I have opened up my firewall and still the same
>> > hanging..
>> > Clients and broker are running on the same localhost...
>> >
>> > Any ideas?
>> >
>> > Thanks,
>> > -Kristoffer
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Client-hangs-in-MulticastDiscoveryAgent-tf2471996.html#a6894562
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> Cheers,
> Guillaume Nodet
> 
> 

-- 
View this message in context: http://www.nabble.com/Client-hangs-in-MulticastDiscoveryAgent-tf2471996.html#a6894832
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message