activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phaiboon <phaibo...@gmail.com>
Subject Re: Messages not dispatch when the brokers reconnect
Date Tue, 17 Oct 2006 08:29:10 GMT

I tried the patches and it now works.
Thanks a lot.


yaussy wrote:
> 
> Assuming you are using AMQ 4.0.1/2, then I'd check out the patches for the
> following issues:
> 
> AMQ-961
> AMQ-776
> 
> 
> 
> Adrian Co wrote:
>> 
>> Which version of ActiveMQ are you running? Are you using queues or
>> topics?
>> 
>> 
>> Phaiboon wrote:
>>> Hi,
>>> I'm Setting up 2 brokers in two separate machines (i.e. producer broker
>>> and
>>> consumer broker). A networkconnector is configured in the producer
>>> broker
>>> connecting to the consumer broker. I have a producer program putting
>>> messages to the producer broker, and a consumer program getting the
>>> messages
>>> from the producer broker.
>>>
>>> Everything is working OK when both brokers are running. Messages put to
>>> the
>>> producer broker are well received by the consumer brokers. When I
>>> shutdown
>>> the consumer broker, the messages remain in the producer broker. I'm
>>> expecting that when the consumer broker is restarted the messages in the
>>> producer broker will be automatically dispatched to the consumer broker.
>>>
>>> However, when I restart the consumer broker, the messages in the
>>> producer
>>> broker are not dispatched to the consumer broker. The log shows that the
>>> connection has been re-established between the producer and consumer
>>> brokers
>>> , but the messages are never dispatched. Any new messages put into the
>>> producer broker are also not dispatched to the consumer broker.
>>>
>>> I have to restart the producer broker to have the messages dispatched to
>>> the
>>> consumer broker.
>>>
>>> Is this the expected behaviour? Did I miss anything here? Really
>>> appreciate
>>> any advice.
>>> Thanks a lot in advance.
>>>
>>>   
>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Messages-not-dispatch-when-the-brokers-reconnect-tf2436937.html#a6850582
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message