activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From me9999...@wwcw.org>
Subject Re: ActiveMQ Message Group Problems -- Exclusive Consumer Works Fine
Date Mon, 16 Oct 2006 23:24:35 GMT


By "listening to a message group" I mean the consumer sets JMSXGroupID to
the message group name upon creation.  The producer sends messages to that
message group.  There is one message group in my test.


James.Strachan wrote:
> 
> On 10/16/06, me9999 <m@wwcw.org> wrote:
>>
>> I'm having a little trouble implementing a message group test.  Say I
>> have
>> two consumers running in separate
>> processes, one listens to a message group and the other listens to the
>> queue.
> 
> There's no difference between listening to a message group or
> listening to a queue. You just have consumers listening to a queue -
> then if a message has a message group ID on it, the broker will
> stickly load balance those messages.
> 
> 
>>   If the consumer listening to the queue starts up first, followed by
>> the consumer listening to the message group, the consumer listening to
>> the
>> queue always gets all the messages, even though the messages are sent to
>> the
>> message group.
> 
> How many message groups do you have?
> 
> 
>> Note
>> that I do not start sending messages until both consumers are connected.
> 
> That shouldn't make any difference.
> 
> 
>> Also note, this problem only occurs when the consumers are running in
>> separate processes.  If both consumers are running in the same process,
>> the
>> consumer that listens to the message group always gets the messages, even
>> if
>> it connects last.
> 
> What do you mean by 'listen to the message group'?
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ-Message-Group-Problems----Exclusive-Consumer-Works-Fine-tf2452172.html#a6845485
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message