activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From craigh <cra...@top-freegames.com>
Subject embedded activemq with spring
Date Thu, 12 Oct 2006 01:35:23 GMT

Hi,

I have recently upgraded my Spring to the 2.0 release, and now I cannot
start the embedded jms broker from within my app context.

I get an error which it seems was seen (and maybe fixed?) earlier this year,
but I cannot figure out what magic combination of jars to use, to resolve. 
I was using one of the recent rc's for Spring and had it working, but now in
my upgrade process I seem to have hosed it.

Here is interesting part of error message:

java.lang.IllegalStateException: Unable to create namespace handler for: v2b

...

Caused by: java.lang.NoClassDefFoundError:
org/springframework/beans/factory/support/ReaderContext
	at
org.apache.xbean.spring.context.v2b.XBeanBeanDefinitionParserDelegate.<init>(XBeanBeanDefinitionParserDelegate.java:45)
	... 47 more

I see there are a few XBean-Spring jars...namely v2, v2a, v2b.  It is also
not clear to me which jar of activemq core, and activeio I should be using.

I tried to stop using the xbean to set up the broker, and use the <bean>
syntax, but it seems to just die the same way when parsing my activemq.xml
file.

Any tips would be much appreciated.

Thanks,
Craig

-- 
View this message in context: http://www.nabble.com/embedded-activemq-with-spring-tf2427412.html#a6768322
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message