activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: ActiveMQ 4.1 hangs when using kaha persistence
Date Wed, 18 Oct 2006 22:01:23 GMT
This is now fixed in SVN head
On 18 Oct 2006, at 11:03, ojs wrote:

>
> Hello,
>
> I have a really simple test scenario - I send 100 strings to the  
> queue and
> the consumer just increses an internal counter when consuming the  
> messages.
> When using journaledJDBC for persistence I can run this test over  
> and over
> again without any problems - the consumer always consumes all 100  
> messages.
> When using kaha persistence I can only run this test once - the  
> second time,
> ActiveMQ hangs. The last log messages that are printed out are:
>
> [DefaultMessageListenerContainer-1] DEBUG
> org.apache.activemq.broker.region.AbstractRegion  - Adding consumer:
> ID:dev1-35887-1161165322583-3:0:1:1
> [DefaultMessageListenerContainer-1] DEBUG
> org.apache.activemq.broker.region.AbstractRegion  - Adding  
> destination:
> queue://org.apache.activemq.spring.Test.spring.embedded
> [DefaultMessageListenerContainer-1] DEBUG
> org.apache.activemq.kaha.impl.data.DataManager  - End of data file  
> reached
> at (header was invalid): offset = 30992, file = 1, size = 260
> [main] INFO   
> org.springframework.jms.connection.SingleConnectionFactory  -
> Established shared JMS Connection: PooledConnection {
> org.apache.activemq.pool.ConnectionPool@1f48262 }
>
>
> It seems, that the kaha logs got corrupted, but why? The run before  
> ActiveMQ
> stopped without any errors:
>
> [Thread-2] INFO  org.apache.activemq.broker.BrokerService  - ActiveMQ
> Message Broker (localhost, ID:dev1-35536-1161165282638-1:0) is  
> shutting down
> [Thread-2] DEBUG org.apache.activemq.broker.region.AbstractRegion  -
> Removing consumer: ID:dev1-35536-1161165282638-3:0:-1:1
> [Thread-2] INFO  org.apache.activemq.broker.TransportConnector  -  
> Connector
> vm://localhost Stopped
> [Thread-2] INFO  org.apache.activemq.broker.BrokerService  -  
> ActiveMQ JMS
> Message Broker (localhost, ID:dev1-35536-1161165282638-1:0) stopped
>
>
> My environment:
>
> - Java 1.5.0_08 on Linux
> - ActiveMQ 4.1-incubator-20061015.071006-56
> - XBean 2.7-SNAPSHOT
> - Spring 2.0
> - Kaha log-directory is on my local disk
>
> Any hints?
>
>
> Best
>
> Oliver
> -- 
> View this message in context: http://www.nabble.com/ActiveMQ-4.1- 
> hangs-when-using-kaha-persistence-tf2465546.html#a6873028
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


Mime
View raw message