activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor Bondarenko" <i...@nsirad.com>
Subject RE: Where to find pom.xml for maven2 ?
Date Tue, 17 Oct 2006 13:28:02 GMT
James,
The problem with Maven2 and the 4.1 snapshot version is it appears to
have inconsistent dependencies that break the Maven2 dependency chain. I
posted details on this a few days back (see
http://www.nabble.com/Maven2-and-ActiveMQ-4.1-snapshot-tf2382371.html#a6
639639), but got no reply on it.

Any help will be greatly appreciated.

-Igor



-----Original Message-----
From: James Strachan [mailto:james.strachan@gmail.com] 
Sent: Tuesday, October 17, 2006 9:19 AM
To: activemq-users@geronimo.apache.org
Subject: Re: Where to find pom.xml for maven2 ?

You can find the snapshots of 4.1 in the apache m2 repo - there are
links to them on the download page...

http://incubator.apache.org/activemq/download.html

e.g.

http://people.apache.org/maven-snapshot-repository/org/apache/activemq/

On 10/17/06, Igor Bondarenko <igor@nsirad.com> wrote:
> Here is how you can get the 4.0.1 release to work with Maven 2:
>
> 1. Add the Codehaus repository to your POM first:
>
>   <repositories>
>     <repository>
>       <id>activemq</id>
>       <name>activemq</name>
>       <url>http://dist.codehaus.org/wadi/dependencies/maven2</url>
>     </repository>
>   </repositories>
>
> 2. Add the ActiveMQ 4.0.1 dependency -- note that the group ID is 
> incubator-activemq, as opposed to activemq per your original email:
>
>     <dependency>
>       <groupId>incubator-activemq</groupId>
>       <artifactId>activemq</artifactId>
>       <version>4.0.1</version>
>     </dependency>
>
> P.S. I did not find a solution to the Maven2/ActiveMQ 4.1 snapshot 
> issue I posted earlier, so if you can figure that out, please post an
update.
>
> -Igor
>
>
>
> -----Original Message-----
> From: christophe blin [mailto:cblin@tennaxia.com]
> Sent: Tuesday, October 17, 2006 8:56 AM
> To: activemq-users@geronimo.apache.org
> Subject: Where to find pom.xml for maven2 ?
>
>
> Hi,
>
> I recently did a prototype with ActiveMQ and Spring for our next 
> messaging system.
> The prototype went well so we are goig to integrate it into the main 
> code base.
>
> The problem is that the main code base uses maven2 as its build
system.
> And doing :
>     <dependency>
>       <groupId>activemq</groupId>
>       <artifactId>activemq</artifactId>
>       <version>4.0.1</version>
>     </dependency>
>
> does not work because 1/ the 4.0.1 does not exist in the ibiblio 
> repository and 2/ in the pom.xml at ibiblio the dependencies are 
> written like this :
> "xxx-${version}" so maven will not find the correct xxx-version.jar
>
> So my question is : for those using activeMQ with maven2, where did 
> you find the dependencies (i.e how do you write it in your pom.xml) ?
> Note : I had search the issue tracker and the forum without any hit 
> but I would appreciate if you could point me to a post or an issue 
> that I missed.
>
> Best regards,
> Chris
> --
> View this message in context:
> http://www.nabble.com/Where-to-find-pom.xml-for-maven2---tf2459329.htm
> l#
> a6854566
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message