activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: duplicate messages on failover of activeMq 4.0.1
Date Tue, 26 Sep 2006 15:21:43 GMT
Could you try help us to reproduce your problem? What kind of consumer
are you using? Are you sure you are using a single queue - as ActiveMQ
load balances queue messages across the available consumers

On 9/26/06, lweisz <lara.weisz@ubiquity.it> wrote:
>
>
> Hi,
>    I'm doing some tests to upgrade from versione 3.2.2 to version 4.0.1.
> I'm using activemq with JOnAS 6_6_6 application server. My webapp runs under
> jonas with two listener listening on the same queue.
> I do the following test:
> 1- put 1000 messages in the queue
> 2- let about 200 messages being consumed
> 3- kill activemq
> 4- stop jonas
> 5- start activemq
> 6- start jonas with my webapp in autoload
>
> What I see is that the remaining messages are delivered twice.
> If do the same test with 3 listeners on the queue the remaining messages are
> delivered three times
> if I use just one listener everyting is ok.
> If i monitoro the queue with the jconsole I see the correct numbre of
> messages but then they are consumed more than once.
> If I don't kill activemq multiple listener are ok.
>
> Thanks in advance for help.
>
> Lara
> --
> View this message in context: http://www.nabble.com/duplicate-messages-on-failover-of-activeMq-4.0.1-tf2339038.html#a6508914
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message