activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Example Spring XML doesn't work
Date Thu, 21 Sep 2006 17:22:42 GMT
On 9/21/06, C. Benson Manica <ataru@sdf.lonestar.org> wrote:
> On Thu, Sep 21, 2006 at 04:13:59PM +0100, James Strachan wrote:
> > On 9/21/06, C. Benson Manica <ataru@sdf.lonestar.org> wrote:
> > >I am not an XML guru by any stretch, but I have been trying for the
> > >better part of an hour to come up with a Spring XML file that
> > >configures ActiveMQ, with no success.  Out of the box, the
> > >configuration at
> > >
> > >http://www.activemq.org/site/how-do-i-embed-a-broker-inside-a-connection.html
> > >
> > >gives me
> > >
> > >     [java] Exception in thread "main"
> > >     org.springframework.beans.factory.BeanDef
> > >initionStoreException: Line 4107 in XML document from class path resource
> > >[Activ
> > >eMQ.xml] is invalid; nested exception is org.xml.sax.SAXParseException:
> > >cos-nona
> > >mbig: "http://activemq.org/config/1.0":redeliveryPolicy and WC[##any] (or
> > >elemen
> > >ts from their substitution group) violate "Unique Particle Attribution".
> > >During
> > >validation against this schema, ambiguity would be created for those two
> > >particl
> > >es.
> > >     [java] Caused by: org.xml.sax.SAXParseException: cos-nonambig:
> > >     "http://acti
> > >vemq.org/config/1.0":redeliveryPolicy and WC[##any] (or elements from
> > >their subs
> > >titution group) violate "Unique Particle Attribution". During validation
> > >against
> > > this schema, ambiguity would be created for those two particles.
> >
> > So the example on that page does not use any XSDs - so I'm wondering
> > what your XML actually looks like? Also what is the version of
> > ActiveMQ / xbean / spring that you are using?
>
> Scroll down a little on the page - I am using the Spring 2.0 example
> XML, which does use XSD's.

You're XML didn't make it to the Apache mailing list - I guess nabble
removed it.


> I'm using Spring 2.0 RC4, ActiveMQ 4.0.1, and xbean-spring-2.6.  Am I
> missing a jar?

Unfortuantely 4.0.x doesn't support Spring 2 - I suspect you'll need to use 4.1.
-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message