activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: AQ 4.0.2 snapshot networkconnectors excludedDestinations problem
Date Mon, 04 Sep 2006 07:30:02 GMT
I wonder, does using the actual destination name work? Am wondering if
wilcards are not quite supported?

On 9/4/06, nkiesel <nkiesel@tbdnetworks.com> wrote:
>
> Hi,
>
> I use a networkconnector to connect two java apps (named "prim" and 'sec")
> that both have an embedded broker. I have some queues that I want to be
> forwarded, and some others (named e.g. "local.q1") that I don't want to be
> forwarded. There are "local.q1" queues on both "prim" and "sec", but they
> are completely unconnected.
>
> I tried to implement that using
>       <networkConnector name="sec" uri="static://(tcp://sec:61618)"
> failover="true">
>         <excludedDestinations>
>           <queue physicalName="local.>"/>
>         </excludedDestinations>
>       </networkConnector>
>
> However, I see a partial "spill-over": some messages written to "local.q1"
> on "prim" show up in "local.q1" in "sec".  Am I doing something wrong here?
>
> Best,
>   Norbert
>
> --
> View this message in context: http://www.nabble.com/AQ-4.0.2-snapshot-networkconnectors-excludedDestinations-problem-tf2213226.html#a6129794
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message