activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Postgresql type "blob" does not exist
Date Mon, 04 Sep 2006 06:44:48 GMT
It can depend on what JDBC driver you are using and what your
activemq.xml looks like. Could you provide us with your XML
configuration file and the full log of the output - since we try to
auto-detect the JDBC driver and use different SQL for different JDBC
drivers

On 8/31/06, F-kris <entylop@hotmail.com> wrote:
>
> Hi again !
>
> I am trying to set up ActiveMQ persistence with postgreSQL. I have created
> the database activemq in postgres, but when I launch Activemq, I have the
> following error :
>
> RMIConnectorServer started at:
> service:jmx:rmi://localhost/jndi/rmi://localhost:1099/jmxrmi
>
> WARN  DefaultJDBCAdapter             - Could not create JDBC tables; they
> could already exist. Failure was: CREATE TABLE ACTIVEMQ_MSGS(ID INTEGER NOT
> NULL, CONTAINER VARCHAR(250), MSGID_PROD VARCHAR(250), MSGID_SEQ INTEGER,
> EXPIRATION BIGINT, MSG BLOB, PRIMARY KEY ( ID ) )
>
> Message: ERROR: type "blob" does not exist SQLState: 42704 Vendor code: 0
>
>
> Do I have to load a library into postgreSQL server?
>
> Thanks.
>
>
> --
> View this message in context: http://www.nabble.com/Postgresql-type-%22blob%22-does-not-exist-tf2199586.html#a6089370
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message