activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GregC <greg.coulo...@gmail.com>
Subject Re: ClassNotFoundException when loading config file
Date Tue, 19 Sep 2006 14:06:20 GMT

Sure. Here is the complete file. I've trimmed it down to the minimal file
that still causes the CNF exception:

<!-- START SNIPPET: example -->
<beans xmlns="http://activemq.org/config/1.0">

  <bean id="remoteJndi" class="org.springframework.jndi.JndiTemplate">
  	<property name="environment">
		<props>
			<prop
key="java.naming.factory.initial">com.tibco.tibjms.naming.TibjmsInitialContextFactory</prop>
			<prop
key="java.naming.provider.url">tibjmsnaming://<hostname>:7222</prop>
		</props>
	</property>
  </bean>

</beans>
<!-- END SNIPPET: example -->




Adrian Co wrote:
> 
> Hi,
> 
> Could you post the complete xml file?
> 
> Wonder if this is a namespace issue.
> 
> 
> 
> GregC wrote:
>> 
>> Hello,
>> 
>> I am trying to run activemq with the following bean added to the
>> activemq.xml config file:
>> 
>> <bean id="remoteJndi" class="org.springframework.jndi.JndiTemplate">
>>   	<property name="environment">
>> 		<props>
>> 			<prop
>> key="java.naming.factory.initial">com.tibco.tibjms.naming.TibjmsInitialContextFactory</prop>
>> 			<prop key="java.naming.provider.url">tibjmsnaming://<server
>> name>:7222</prop>
>> 		</props>
>> 	</property>
>>   </bean>
>> 
>> This is part of the configuration for the JMS-JMS Bridge, as specified on
>> the ActiveMQ web site. When I run the bin/activemq script with this
>> configuration in place, I get the following error:
>> 
>> ACTIVEMQ_HOME: /home/user/dl/incubator-activemq-4.0.1
>> Loading message broker from: xbean:activemq.xml
>> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
>> org.springframework.beans.factory.BeanDefinitionStoreException: Error
>> registering bean with name '' defined in class path resource
>> [activemq.xml]: Bean class [props] not found; nested exception is
>> java.lang.ClassNotFoundException: props
>> ERROR: java.lang.Exception:
>> org.springframework.beans.factory.BeanDefinitionStoreException: Error
>> registering bean with name '' defined in class path resource
>> [activemq.xml]: Bean class [props] not found; nested exception is
>> java.lang.ClassNotFoundException: props
>> 
>> 
>> Suggestions, anyone?
>> 
>> Thanks, 
>> 
>> Greg
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/ClassNotFoundException-when-loading-config-file-tf2292903.html#a6388881
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message