activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dooart <thiagocdua...@yahoo.com.br>
Subject Re: ActiveMQ, Clustered JBoss and JDBC Master/Slave
Date Fri, 01 Sep 2006 23:29:21 GMT

Oops... I forgot to attach the configuration files:
http://www.nabble.com/user-files/235843/configuration_files.zip
configuration_files.zip 

Thiago Duarte


dooart wrote:
> 
> I am trying to setup an environment with a clustered JBoss and ActiveMQ in
> JDBC Master/Slave mode. I'm going to use JMS in our application to help in
> some issues with clustering, like indexing and local files
> synchronization.
> 
> I have only two machines to run the entire environment and I want to run
> an embedded ActiveMQ broker per application server to help in application
> maintenance, so the final environment will be something like this:
> 
> At first it seemed to be working fine, but when I started to test the
> behaviour of the environment shutting down the nodes and restarting them,
> I started to have some problems with message duplication and lost
> messages. Here are the results of some tests I made (errors are marked
> with red color):
> 
> ...
> 
> I've run the first test with MySQL 5.0 and the second test with MSSQL
> Server 2000 as datasources for JDBC Master/Slave, but both configurations
> failed as you can see at the two tables above. I'm almost sure that the
> steps 4 and 5 from the second test failed not because of MSSQL, but
> because the instability of the entire environment.
> 
> Does anyone have a clue of what can be wrong? I don't know if this helps,
> but I've attached my configuration files here.
> 
> I'm using JBoss 4.0.4 GA and ActiveMQ 4.1 (I was using 4.0.1 before, but
> it didn't work too).
> 
> 
> Thanks,
> 
> Thiago Duarte
> 

-- 
View this message in context: http://www.nabble.com/ActiveMQ%2C-Clustered-JBoss-and-JDBC-Master-Slave-tf2204736.html#a6107815
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message