activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Co <...@exist.com>
Subject Re: running broker with gij
Date Mon, 04 Sep 2006 02:25:15 GMT
Hi,

Which version of ActiveMQ are you using? Could try adding this to as a 
command line parameter: xbean:activemq.xml?
i.e.

gij --jar run.jar -Dgnu.gcj.precompiled.db.path=classmap.db
-Dorg.apache.activemq.UseDedicatedTaskRunner=true
-Dderby.system.home=../data -Dderby.storage.fileSyncTransactionLog=true
-Dcom.sun.management.jmxremote org.apache.activemq.console.Main xbean:activemq.xml

Regards,
Adrian Co


rubyfan wrote:
> I'm trying to run the broker with gij.  I use the following command:
>
> gij --jar run.jar -Dgnu.gcj.precompiled.db.path=classmap.db
> -Dorg.apache.activemq.UseDedicatedTaskRunner=true
> -Dderby.system.home=../data -Dderby.storage.fileSyncTransactionLog=true
> -Dcom.sun.management.jmxremote org.apache.activemq.console.Main
>
> I'm getting the following:
>
> ACTIVEMQ_HOME: .
> Loading message broker from: org.apache.activemq.console.Main
> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
> java.lang.IllegalArgumentException: Invalid broker URI, no scheme specified:
> org.apache.activemq.console.Main
> ERROR: java.lang.Exception: java.lang.IllegalArgumentException: Invalid
> broker URI, no scheme specified: org.apache.activemq.console.Main
>
> When the activemq script is run to start the broker in the conventional way
> there doesn't seem to be any URI specified.  What URI is it looking for?
>
>
>   


Mime
View raw message