activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: .NET Broker
Date Mon, 21 Aug 2006 07:38:41 GMT
Great stuff - thanks for the heads up! :)

On 8/19/06, Pieter van der Merwe <pvanderm@theenablergroup.com> wrote:
> Just for future reference, the log4j jar was not included in my ikvmc
> build. This caused the issue.
>
> After including the jar for it, the ServiceBroker is successfully
> created.
>
> Thanks for the help.
>
> -----Original Message-----
> From: Pieter van der Merwe
> Sent: 19 August 2006 01:31 PM
> To: activemq-users@geronimo.apache.org
> Subject: .NET Broker
>
> Okay. I've made some progress on this, the code that is actually falling
> over is the following [.NET]:
>
>
>
> String value = uri.getSchemeSpecificPart();
>
>
>
> org.apache.xbean.spring.context.ClassPathXmlApplicationContext context =
> new
> org.apache.xbean.spring.context.ClassPathXmlApplicationContext(value);
>
>
>
> I translated this to .NET, the value of the value variable is
> activemq.xml, but what is strange here is that the logging part is
> actually falling over as follows:
>
>
>
> org.apache.commons.logging.LogConfigurationException:
> org.apache.commons.logging.LogConfigurationException: No suitable Log
> constructor [Ljava.lang.Class;@1e61ea5 for
> org.apache.commons.logging.impl.Log4JLogger (Caused by
> java.lang.NoClassDefFoundError: org.apache.log4j.Logger) (Caused by
> org.apache.commons.logging.LogConfigurationException: No suitable Log
> constructor [Ljava.lang.Class;@1e61ea5 for
> org.apache.commons.logging.impl.Log4JLogger (Caused by
> java.lang.NoClassDefFoundError: org.apache.log4j.Logger)).
>
>
>
> Does this mean that the log4j.properties is not being picked up?
>
>
>
> Thanks in Advance
>
>
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message