activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Build error with maven2.0.4
Date Fri, 11 Aug 2006 08:08:35 GMT
Sometimes maven doesn't manage to download the dependencies it
requires so you sometimes have to runa build a few times to get it to
download everything. Could you try a few more times to be sure?

On 8/11/06, cob <cuizhongfa@yahoo.com> wrote:
>
>  Can you help me ?  I build the source using maven2.0.4 and JDK1.5.0_06, but
> build error as following:
>
>     Internal error in the plugin manager executing goal
> 'org.apache.maven.plu
>     gins:maven-antrun-plugin:1.1:run': Unable to find the mojo
> 'org.apache.maven.plu
>     gins:maven-antrun-plugin:1.1:run' in the plugin
> 'org.apache.maven.plugins:maven-
>     antrun-plugin'
>     org/apache/tools/ant/PropertyHelper
>
>
> C:\incubator-activemq-4.0.1>mvn -Dmaven.test.skip=true install
> [INFO] Scanning for projects...
> [INFO] Reactor build order:
> [INFO]   ActiveMQ
> [INFO]   ActiveMQ :: JAAS
> [INFO]   ActiveMQ :: Core
> [INFO]   ActiveCluster
> [INFO]   ActiveMQ :: Console
> [INFO]   ActiveMQ :: RA
> [INFO]   ActiveMQ :: RAR
> [INFO]   ActiveMQ :: Web
> [INFO]   ActiveMQ :: Web Demo
> [INFO]   ActiveMQ :: Optional
> [INFO]   Bundle Plugin
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] Building ActiveMQ
> [INFO]    task-segment: [install]
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] [site:attach-descriptor]
> [INFO] [install:install]
> [INFO] Installing C:\incubator-activemq-4.0.1\pom.xml to C:\Documents and
> Settin
> gs\cuizhongfa.CCDOMAIN.000\.m2\repository\incubator-activemq\activemq-parent\4.0
> .1\activemq-parent-4.0.1.pom
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] Building ActiveMQ :: JAAS
> [INFO]    task-segment: [install]
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [WARNING] POM for 'directory-protocols:kerberos-protocol:pom:0.5:test' is
> invali
> d. It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-protocols:ldap-protocol:pom:0.9.2:test' is
> invalid.
>  It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:ldap-common:pom:0.9.2:test' is invalid.
> It w
> ill be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-shared:pom:0.9.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-asn1:asn1-der:pom:0.3.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-network:mina:pom:0.7.3:test' is invalid. It
> will be
>  ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-core:pom:0.9.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:apache-ldapber-provider:pom:0.9.2:test'
> is i
> nvalid. It will be ignored for artifact resolution. Reason: Not a v4.0.0
> POM.
> [WARNING] POM for 'directory-asn1:asn1-codec:pom:0.3.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:kerberos-common:pom:0.5:test' is
> invalid. It
>  will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [INFO] [compiler:compile]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [resources:testResources]
> [INFO] Using default encoding to copy filtered resources.
> [WARNING] POM for 'directory-protocols:kerberos-protocol:pom:0.5:test' is
> invali
> d. It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-protocols:ldap-protocol:pom:0.9.2:test' is
> invalid.
>  It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:ldap-common:pom:0.9.2:test' is invalid.
> It w
> ill be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-shared:pom:0.9.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-asn1:asn1-der:pom:0.3.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-network:mina:pom:0.7.3:test' is invalid. It
> will be
>  ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-core:pom:0.9.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:apache-ldapber-provider:pom:0.9.2:test'
> is i
> nvalid. It will be ignored for artifact resolution. Reason: Not a v4.0.0
> POM.
> [WARNING] POM for 'directory-asn1:asn1-codec:pom:0.3.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:kerberos-common:pom:0.5:test' is
> invalid. It
>  will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [INFO] [compiler:testCompile]
> [INFO] Not compiling test sources
> [WARNING] POM for 'directory-protocols:kerberos-protocol:pom:0.5:test' is
> invali
> d. It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-protocols:ldap-protocol:pom:0.9.2:test' is
> invalid.
>  It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:ldap-common:pom:0.9.2:test' is invalid.
> It w
> ill be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-shared:pom:0.9.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-asn1:asn1-der:pom:0.3.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-network:mina:pom:0.7.3:test' is invalid. It
> will be
>  ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory:apacheds-core:pom:0.9.2:test' is invalid. It
> will b
> e ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:apache-ldapber-provider:pom:0.9.2:test'
> is i
> nvalid. It will be ignored for artifact resolution. Reason: Not a v4.0.0
> POM.
> [WARNING] POM for 'directory-asn1:asn1-codec:pom:0.3.2:test' is invalid. It
> will
>  be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [WARNING] POM for 'directory-shared:kerberos-common:pom:0.5:test' is
> invalid. It
>  will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> [INFO] [surefire:test]
> [INFO] Tests are skipped.
> [INFO] [jar:jar]
> [INFO] Building jar:
> C:\incubator-activemq-4.0.1\activemq-jaas\target\activemq-j
> aas-4.0.1.jar
> [INFO] [install:install]
> [INFO] Installing
> C:\incubator-activemq-4.0.1\activemq-jaas\target\activemq-jaas
> -4.0.1.jar to C:\Documents and
> Settings\cuizhongfa.CCDOMAIN.000\.m2\repository\i
> ncubator-activemq\activemq-jaas\4.0.1\activemq-jaas-4.0.1.jar
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] Building ActiveMQ :: Core
> [INFO]    task-segment: [install]
> [INFO]
> -------------------------------------------------------------------------
> ---
> [WARNING] While downloading javacc:javacc:3.2
>   This artifact has been relocated to net.java.dev.javacc:javacc:3.2.
>
>
> [INFO] [javacc:javacc {execution: default}]
> [INFO] Nothing to process - all grammars are up to date
> [WARNING]
>         Artifact junit:junit:jar:3.8.1:test retains local scope 'test'
> overridin
> g broader scope 'runtime'
>         given by a dependency. If this is not intended, modify or remove the
> loc
> al scope.
>
> [WARNING]
>         Artifact commons-collections:commons-collections:jar:2.1:test
> retains lo
> cal scope 'test' overriding broader scope 'compile'
>         given by a dependency. If this is not intended, modify or remove the
> loc
> al scope.
>
> [WARNING]
>         Artifact ant:ant:jar:1.6.5:runtime retains local scope 'runtime'
> overrid
> ing broader scope 'compile'
>         given by a dependency. If this is not intended, modify or remove the
> loc
> al scope.
>
> -----------------------------------------------------
> this realm = plexus.core.maven
> urls[0] = file:/C:/maven-2.0.4/bin/../lib/commons-cli-1.0.jar
> urls[1] = file:/C:/maven-2.0.4/bin/../lib/doxia-sink-api-1.0-alpha-7.jar
> urls[2] = file:/C:/maven-2.0.4/bin/../lib/jsch-0.1.24.jar
> urls[3] = file:/C:/maven-2.0.4/bin/../lib/maven-antrun-plugin-1.1.jar
> urls[4] = file:/C:/maven-2.0.4/bin/../lib/maven-artifact-2.0.4.jar
> urls[5] = file:/C:/maven-2.0.4/bin/../lib/maven-artifact-manager-2.0.4.jar
> urls[6] = file:/C:/maven-2.0.4/bin/../lib/maven-core-2.0.4.jar
> urls[7] = file:/C:/maven-2.0.4/bin/../lib/maven-error-diagnostics-2.0.4.jar
> urls[8] = file:/C:/maven-2.0.4/bin/../lib/maven-model-2.0.4.jar
> urls[9] = file:/C:/maven-2.0.4/bin/../lib/maven-monitor-2.0.4.jar
> urls[10] = file:/C:/maven-2.0.4/bin/../lib/maven-plugin-api-2.0.4.jar
> urls[11] = file:/C:/maven-2.0.4/bin/../lib/maven-plugin-descriptor-2.0.4.jar
> urls[12] =
> file:/C:/maven-2.0.4/bin/../lib/maven-plugin-parameter-documenter-2.0
> .4.jar
> urls[13] = file:/C:/maven-2.0.4/bin/../lib/maven-plugin-registry-2.0.4.jar
> urls[14] = file:/C:/maven-2.0.4/bin/../lib/maven-profile-2.0.4.jar
> urls[15] = file:/C:/maven-2.0.4/bin/../lib/maven-project-2.0.4.jar
> urls[16] = file:/C:/maven-2.0.4/bin/../lib/maven-reporting-api-2.0.4.jar
> urls[17] =
> file:/C:/maven-2.0.4/bin/../lib/maven-repository-metadata-2.0.4.jar
> urls[18] = file:/C:/maven-2.0.4/bin/../lib/maven-settings-2.0.4.jar
> urls[19] =
> file:/C:/maven-2.0.4/bin/../lib/plexus-interactivity-api-1.0-alpha-4.
> jar
> urls[20] = file:/C:/maven-2.0.4/bin/../lib/wagon-file-1.0-alpha-7.jar
> urls[21] =
> file:/C:/maven-2.0.4/bin/../lib/wagon-http-lightweight-1.0-alpha-6.ja
> r
> urls[22] =
> file:/C:/maven-2.0.4/bin/../lib/wagon-provider-api-1.0-alpha-6.jar
> urls[23] = file:/C:/maven-2.0.4/bin/../lib/wagon-ssh-1.0-alpha-7.jar
> urls[24] =
> file:/C:/maven-2.0.4/bin/../lib/wagon-ssh-external-1.0-alpha-6.jar
> Number of imports: 0
>
>
> this realm = plexus.core
> urls[0] =
> file:/C:/maven-2.0.4/bin/../core/plexus-container-default-1.0-alpha-9.
> jar
> urls[1] = file:/C:/maven-2.0.4/bin/../core/plexus-utils-1.1.jar
> Number of imports: 0
> -----------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Internal error in the plugin manager executing goal
> 'org.apache.maven.plu
> gins:maven-antrun-plugin:1.1:run': Unable to find the mojo
> 'org.apache.maven.plu
> gins:maven-antrun-plugin:1.1:run' in the plugin
> 'org.apache.maven.plugins:maven-
> antrun-plugin'
> org/apache/tools/ant/PropertyHelper
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 4 seconds
> [INFO] Finished at: Thu Aug 10 14:38:21 CST 2006
> [INFO] Final Memory: 8M/16M
> [INFO]
> ------------------------------------------------------------------------
>
> --
> View this message in context: http://www.nabble.com/Build-error-with-maven2.0.4-tf2088342.html#a5755911
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message