activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: "No subscriptions registered"
Date Tue, 01 Aug 2006 07:32:56 GMT
It just sounds like you are publishing to a queue which has no consumers.

e.g. try looking at the queues and the available consumers using JMX
http://incubator.apache.org/activemq/jmx.html

On 8/1/06, mjanveaux <mark@mobiledesigntech.com> wrote:
>
> Hello,
>
> I'm new to activeMQ but have managed to get it integrated into my
> application which uses tomcat and spring using an embedded broker.
>
> I am running some tests (where I want to receive data from a socket and
> store it on a queue determined at runtime) and, while everything seems to be
> successful, it only publishes one message and then seems to block.  I'm
> getting the following message in my log:
>
> DEBUG 31/07/2006 16:17:58 ActiveMQ Transport: tcp:///127.0.0.1:1675
> org.apache.activemq.broker.region.Queue.GEMMS.5 - No subscriptions
> registered, will not dispatch message at this time.
>
>
> at which point it seems to block... here's a bit more of the log which may
> help to explain what I'm doing:
>
>
> INFO 31/07/2006 16:17:58 Thread-66  com.mdt.hl7.server.ConsoleServer -
> Accepted connection.
>
> INFO 31/07/2006 16:17:58 Thread-66  com.mdt.hl7.server.ConsoleServer -
> onNewConnection: 72487616
> INFO 31/07/2006 16:17:58 Thread-66  com.mdt.hl7.server.ConsoleServer -
> client IP: 16777343
> INFO 31/07/2006 16:17:58 Thread-66  com.mdt.hl7.server.ConsoleServer -
> client address: 127.0.0.1
> INFO 31/07/2006 16:17:58 Thread-67  com.mdt.hl7.server.ConsoleServer - New
> Message: 72487616
> DEBUG 31/07/2006 16:17:58 ActiveMQ Transport: tcp:///127.0.0.1:1675
> org.apache.activemq.store.journal.JournalMessageStore - Journalled message
> add for: ID:MARKSDELL-1655-1154387838542-3:3:1:1:1, at: 0:6616
> DEBUG 31/07/2006 16:17:58 ActiveMQ Transport: tcp:///127.0.0.1:1675
> org.apache.activemq.broker.region.Queue.GEMMS.5 - No subscriptions
> registered, will not dispatch message at this time.
>
>
> Can anybody give me some insight into what may be happening?   Do I have to
> have a consumer registered to pull messages off this queue before sending
> messages to it?
>
> Any help would be appreciated, thanks.
>
> Mark
> --
> View this message in context: http://www.nabble.com/%22No-subscriptions-registered%22-tf2030689.html#a5585971
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message