activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Build error with maven2.0.4
Date Fri, 11 Aug 2006 08:43:32 GMT
Might be something else going on...

I have been using bootstrap in Geronimo quite often now, and the  
first thing it does is nuke ~/.m2/repository to ensure that a clean  
install will work.

Granted sometimes m2 freakes... but it should be able to dl  
everything in one shot if the planets align and the gods favor you.

I'd recommend limiting your dependence on external repos as much as  
possible... where possible that is.  Defs limit the number of repos,  
and with m2, try to avoid using m1 repos... and where needed only  
list that m1 repo in specific modules that need m1 artifacts.

You *should* be able to get a clean build from one mvn... if this  
ends up painful for folks lemme know and I can peek at your build.

Cheers,

--jason


On Aug 11, 2006, at 1:17 AM, James Strachan wrote:

> On 8/11/06, Jason Dillon <jason@planet57.com> wrote:
>> Huh?  Sounds kinda fishy to me... m2 should be able to download
>> everything in one shot... assuming that network connectivity is good.
>>
>> Are you guys seeing this often?
>
> Yes - I've seen this quite a bit. its usually the repo that hosts a
> jar having a bad day. Sometimes takes a few goes to get everything.
>
> e.g. if you trash your entire ~/.m2/repository and do a build it often
> takes a couple of goes.
> -- 
>
> James
> -------
> http://radio.weblogs.com/0112098/


Mime
View raw message