activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cui, Fanzhe" <fanzhe....@intel.com>
Subject RE: Problem with ActiveMQ Client C project
Date Tue, 08 Aug 2006 00:17:53 GMT
Hi Hiram,

Thank you for the response. I will try it immediately.

Fanz 

-----Original Message-----
From: chirino@gmail.com [mailto:chirino@gmail.com] On Behalf Of Hiram
Chirino
Sent: Monday, August 07, 2006 8:08 PM
To: activemq-users@geronimo.apache.org
Subject: Re: Problem with ActiveMQ Client C project

Hi Fanz,

try the one from here: http://svn.activemq.org/trunk/openwire-c/

On 8/7/06, Cui, Fanzhe <fanzhe.cui@intel.com> wrote:
> I was trying to have a simple testing with the C Client (Open Wire) to
> ActiveMQ. I downloaded the C client project from the link:
> http://svn.activemq.org/branches/activemq-4-0/activemq/openwire-c/
> When I was building the project with MS VC++, I got the following
> compiler error from ow_commands_v1.c file:
>
c:\downloads\activeMQ\c_client_v4.1\src\libopenwire\ow_commands_v1.c(86)
> : error C2065: 'OW_PARTIALCOMMAND_TYPE' : undeclared identifier
>
c:\downloads\activeMQ\c_client_v4.1\src\libopenwire\ow_commands_v1.c(87)
> : error C2065: 'OW_LASTPARTIALCOMMAND_TYPE' : undeclared identifier
>
> It looked like that the file which had the definition of
> OW_PARTIALCOMMAND_TYPE missing. But I searched all source files and
> header files that contained in the project and none of them had the
> definition of OW_PARTIALCOMMAND_TYPE.
>
> I think someone must have successfully built the project with VC++.
But
> strange to me that the definitions were mising. If someone can shed
> lights on this problem, it would be appreciated.
>
> Regards,
> Fanz
>
>


-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Mime
View raw message