activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dooart <>
Subject ActiveMQ + JBoss
Date Mon, 14 Aug 2006 15:24:39 GMT


I'm using an embedded broker started with the provided JCA resource adapter
and I've made an example like the one at the deployment guide page for
JBoss. Everything seems to be working fine, except for the fact that my MDB
doesn't receive the messages sent to the queue that it should listen. I
believe that I'm doing some wrong ActiveMQ configuration, because when I
point the MDB (and make some minor changes to ejb-jar and jboss-jar) to
listen to a pre-configured JBossMQ queue, it works fine. I've tried to fix
this for the last five days and I'm stuck, so I decided to ask for help here
before losing all my hair. =)

I'm using [trying to use] ActiveMQ 4.0.1 and JBoss 4.0.4 GA with

I don't know if this helps, but I made some tests:
- I tried to produce and consume messages using tcp to connect to the broker
started by the resource adapter and it worked.
- I tried to produce messages using jndi to get the connection factory and
the queue and consume those messages using tcp to connect to a queue by it's
physical name and it worked too.

Does someone know what I'm doing wrong? The relevant files are attached.

Thanks in advance. activemq-ds.xml broker-config.xml ejb-jar.xml jboss.xml ra.xml 
View this message in context:
Sent from the ActiveMQ - User forum at

View raw message