activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Xie <ant_mira...@163.com>
Subject Re: can network of brokers dothis feature?
Date Mon, 14 Aug 2006 01:29:08 GMT

Thanks John for your reply!
I try to do it as your suggestion that testing it on removing the
destionation inclusions setting, but the problem still exists.


John Heitmann wrote:
> 
> Ah, you're getting that from http://www.activemq.org/site/networks-of- 
> brokers.html which looks like it has some bad character escaping or  
> something going on. Try instead:
> 
I actually check the character by ultraedit, not finding any bad character
escaping.

Follow is my testing steps:
A: start brokerA with network of brokers conf, see example as follow
    <networkConnectors>
			<networkConnector name="broker19" uri="static://(tcp://ip1:61616)"
failover="true" networkTTL="2"/>
    </networkConnectors>

B: start brokerB by default:
C: then brokerA print out "Network connection between vm://localhost#0 and
tcp://ip1:61616(localhost) has been established." means nework connect
successfully.
D: then i send the text message to brokerA, and successfully recieved
message from brokerB. network of brokers works.
E: then i pull the brokerB out of the network service, then i find that
brokerA can't connect to it.
   brokerA print out"WARN  DemandForwardingBridge         - Outbound
transport to localhost interruptted"
F: then i send the text message again to brokerA, so the message can't be
pass to brokerB as of can't be connected to brokerB.
G: then i recover the net work service for brokerB, and brokerA print out
"Network connection between vm://localhost#0 and tcp://ip1:61616(localhost)
has been established." again
H: then i try to recieve message from brokerB, nothing recieved. even if
send more messages to brokerA, no message passes to brokerB.
I: if i want it to be work again, just need to restart brokerA then i works
now.( it's a bad feeling to do it)

Here is my question again:
1. could anyone tell me the failure of my testing is that network of brokers
not provide such feature or is there something I configure it error or
mistake?

could anyone do me a favor? Thx!

Matt.






John Heitmann wrote:
> 
> 
> On Aug 11, 2006, at 2:51 AM, Matthew Xie wrote:
> 
>>
>> Hi every!
>> I have two brokers, brokerA and brokerB.
>> I want to brokerA and brokerB establish the feature of network of  
>> brokers.
>> when I send message to brokerA, it will passed the message to the  
>> BrokerB.
>> here I need to notice that if brokerB fail down, then the messages  
>> be send
>> to brokerA cann't pass the messages to the brokerB. can network of  
>> brokers
>> do this feature if brokerB startup all the message live in brokerA  
>> could
>> pass to brokerB if they reestablish the network of brokers.
> 
> Yup, network of brokers should be perfect for this.
> 
>> following is my conf. i try to do it , but failed. could some one  
>> tell me is
>> here something wrong??
>>
>> BrokerA:
>>       <networkConnector name="broker19" uri="static://(tcp:// 
>> ip1:61616)"
>> failover="true" networkTTL="2">
>>          name=bridgeA
>>          dynamicOnly=false
>>          conduitSubscriptions=true
>>          decreaseNetworkConsumerPriority=false
>>
>>    			<staticallyIncludedDestinations>
>>    				<queue physicalName="QP_TEST.Queue"/>
>>    			</staticallyIncludedDestinations>
>>       	<dynamicallyIncludedDestinations>
>>       		<queue physicalName="QP_TEST.Queue"/>
>>       	</dynamicallyIncludedDestinations>
>>
>>       </networkConnector>
> 
> Ah, you're getting that from http://www.activemq.org/site/networks-of- 
> brokers.html which looks like it has some bad character escaping or  
> something going on. Try instead:
> 
> <networkConnectors>
>        <networkConnector name="broker19" uri="static://(tcp:// 
> ip1:61616)" failover="true" networkTTL="2"/>
> </networkConnectors>
> 
> Once you get that working you can add the destination inclusions back  
> in.
> 
> If you're on linux you can run 'xmllint --noout activemq.xml' to get  
> help showing ill-formed xml constructs in your config.
> 
> John
> 
> 

-- 
View this message in context: http://www.nabble.com/can-network-of-brokers-dothis-feature--tf2089718.html#a5790290
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message