activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lalit Nagpal <lalitte...@rediffmail.com>
Subject RE: Problem with ActiveMQ Client C project
Date Fri, 11 Aug 2006 06:01:29 GMT

I guess the examples given on the site are not updated to reflect the latest
changes done to the repository code for both ActiveMQ CPP Client and C
client therefore we are unable to compile these.

I was able to resolve some of these errors when i tried the activemq-cpp
client. Somebody please kindly update the examples as that is the starting
point for all of us.

Thanks

Lalit Nagpal



Cui, Fanzhe wrote:
> 
> Hi,
> 
> I just sent out email accidentally. Sorry about that.
> 
> This is the right email.
> 
> I tried the project files from the link you provided in the last email,
> but the result was the same as before. This time I guess I did miss
> something when building the project, because I think you and other
> developers must have tried the project into successful build. But I
> really cannot figure out what was the problem. My logic was that
> OW_PARTIALCOMMAND_TYPE must be defined in a c source file or header file
> somewhere because the definition of this identifier was not in any files
> below in the project:
> Amqcs.c
> Amqcs.h
> ow.c
> ow.h
> Ow_commands_v1.c
> Ow_commands_v1.h
> Ow_commands_types_v1.h
> Ow_marshal.c
> Main.c
> 
> If someone has successfully built the project, he must know that in
> which file OW_PARTIALCOMMAND_TYPE is defined. Can you check your project
> and find which file contain OW_PARTIALCOMMAND_TYPE definition? Also in
> case you want to look at my project file, I attach my project file to
> this email. BTW I am building the project with MS Visual Studio 7.2.
> 
> Appreciate your help.
> 
> Regards,
> Fanz
> 
> -----Original Message-----
> From: chirino@gmail.com [mailto:chirino@gmail.com] On Behalf Of Hiram
> Chirino
> Sent: Monday, August 07, 2006 8:08 PM
> To: activemq-users@geronimo.apache.org
> Subject: Re: Problem with ActiveMQ Client C project
> 
> Hi Fanz,
> 
> try the one from here: http://svn.activemq.org/trunk/openwire-c/
> 
> On 8/7/06, Cui, Fanzhe <fanzhe.cui@intel.com> wrote:
>> I was trying to have a simple testing with the C Client (Open Wire) to
>> ActiveMQ. I downloaded the C client project from the link:
>> http://svn.activemq.org/branches/activemq-4-0/activemq/openwire-c/
>> When I was building the project with MS VC++, I got the following
>> compiler error from ow_commands_v1.c file:
>>
> c:\downloads\activeMQ\c_client_v4.1\src\libopenwire\ow_commands_v1.c(86)
>> : error C2065: 'OW_PARTIALCOMMAND_TYPE' : undeclared identifier
>>
> c:\downloads\activeMQ\c_client_v4.1\src\libopenwire\ow_commands_v1.c(87)
>> : error C2065: 'OW_LASTPARTIALCOMMAND_TYPE' : undeclared identifier
>>
>> It looked like that the file which had the definition of
>> OW_PARTIALCOMMAND_TYPE missing. But I searched all source files and
>> header files that contained in the project and none of them had the
>> definition of OW_PARTIALCOMMAND_TYPE.
>>
>> I think someone must have successfully built the project with VC++.
> But
>> strange to me that the definitions were mising. If someone can shed
>> lights on this problem, it would be appreciated.
>>
>> Regards,
>> Fanz
>>
>>
> 
> 
> -- 
> Regards,
> Hiram
> 
> Blog: http://hiramchirino.com
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-with-ActiveMQ-Client-C-project-tf2069504.html#a5757234
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message